base-files: support label-property-less in get_dt_leds
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 30 Aug 2020 02:42:54 +0000 (04:42 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 5 Sep 2020 21:24:46 +0000 (23:24 +0200)
The LED's "label" property has been deprecated in upstream by:

|commit c5d18dd6b64e09dd6984bda9bdd55160af537a8c
|Author: Jacek Anaszewski <jacek.anaszewski@gmail.com>
|Date:   Sun Jun 9 20:19:04 2019 +0200
|
|    dt-bindings: leds: Add properties for LED name construction
|
|    Introduce dedicated properties for conveying information about
|    LED function and color. Mark old "label" property as deprecated.
|
|    Additionally function-enumerator property is being provided
|    for the cases when neither function nor color can be used
|    for LED differentiation.

in order to be somewhat prepared, this patch adds a fallback
as a last resort to make the current led code work by falling
back to the node-name as the "label".

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/base-files/Makefile
package/base-files/files/lib/functions/leds.sh

index 7eb3ac18685349b9d9b973542b06ba5c2ee227d4..2419849a441f32cc5f0958efb668e2baf04c519d 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=227
+PKG_RELEASE:=228
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 43b2fe02ed8fba4bffb28fff9ec142f0ea25928e..14baeb37b49f9f828b129e28d1500bdb6f04ee72 100644 (file)
@@ -18,7 +18,8 @@ get_dt_led() {
 
        [ -n "$ledpath" ] && \
                label=$(cat "$ledpath/label" 2>/dev/null) || \
-               label=$(cat "$ledpath/chan-name" 2>/dev/null)
+               label=$(cat "$ledpath/chan-name" 2>/dev/null) || \
+               label=$(basename "$ledpath")
 
        echo "$label"
 }