uhttpd: add direct dependency on libjson-c
authorJo-Philipp Wich <jo@mein.io>
Thu, 20 Jun 2019 16:07:49 +0000 (18:07 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 20 Jun 2019 16:09:48 +0000 (18:09 +0200)
The OpenWrt buildroot ABI version rebuild tracker does not handle
transient dependencies, therefor add all libraries linked by uhttpd
as direct dependencies to the corresponding binary package definition.

This ensures that uhttpd is automatically rebuilt and relinked if any
of these libraries has its ABI_VERSION updated in the future.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/uhttpd/Makefile

index caa59249d314da8af7b5fa20beb11acc24aea36f..0738ec68f565c2ad2b233622987ab6a07945b47a 100644 (file)
@@ -34,7 +34,7 @@ endef
 
 define Package/uhttpd
   $(Package/uhttpd/default)
-  DEPENDS:=+libubox +libblobmsg-json +libjson-script
+  DEPENDS:=+libubox +libblobmsg-json +libjson-script +libjson-c
 endef
 
 define Package/uhttpd/description