include/package-dumpinfo.mk: introduce Repository values
authorJo-Philipp Wich <jo@mein.io>
Wed, 13 Apr 2016 13:28:13 +0000 (15:28 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Apr 2016 13:28:13 +0000 (15:28 +0200)
Introduce a new dumpinfo field "Repository" which contains the name of the
shared repository where the package will be hosted in. The name is chosen
according to the following rules:

 - Name of the feed directory for any feed package, e.g. "Repository: luci" for
   "feeds/luci/applications/luci-app-firewall/Makefile"
 - The value "base" for any other, sharable package
 - Unset for any package flagged PKG_FLAGS:=nonshared

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/package-dumpinfo.mk

index 666e9635bb1e4f4b4acf3fb94ec5af06970cf155..04584d5b3ae5e9ce7df1c286cd001ba37f60cdb6 100644 (file)
@@ -41,7 +41,8 @@ $(if $(DEFAULT_VARIANT),Default-Variant: $(VARIANT)
 )$(if $(BUILD_TYPES),Build-Types: $(BUILD_TYPES)
 )Section: $(SECTION)
 Category: $(CATEGORY)
-Title: $(TITLE)
+$(if $(filter nonshared,$(PKG_FLAGS)),,Repository: $(if $(FEED),$(FEED),base)
+)Title: $(TITLE)
 Maintainer: $(MAINTAINER)
 $(if $(USERID),Require-User: $(USERID)
 )Source: $(PKG_SOURCE)