rename br2684.init to br2684.hotplug, normalize Makefile.
authorNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:26:00 +0000 (18:26 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:26:00 +0000 (18:26 +0000)
SVN-Revision: 3996

openwrt/package/linux-atm/Makefile
openwrt/package/linux-atm/files/br2684.hotplug [new file with mode: 0644]
openwrt/package/linux-atm/files/br2684.init [deleted file]

index 5b75e195522f1feb16806119e159ef6bd45a994c..e37d5bdceb55d8ed7ca4494c6d83a7dbd71684dc 100644 (file)
@@ -17,18 +17,18 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(TOPDIR)/package/rules.mk
 
 define Package/linux-atm
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=Linux ATM Library
- DESCRIPTION:=Library for accessing the Linux ATM subsystem
+SECTION:=libs
+CATEGORY:=Libraries
+TITLE:=Linux ATM Library
+DESCRIPTION:=Library for accessing the Linux ATM subsystem
 endef
 
 define Package/br2684ctl
- SECTION:=net
- CATEGORY:=Network
- TITLE:=RFC2684 bridging
- DEPENDS:=+linux-atm
- DESCRIPTION:=ATM RFC2684 bridging utility
+SECTION:=net
+CATEGORY:=Network
+TITLE:=RFC2684 bridging
+DEPENDS:=+linux-atm
+DESCRIPTION:=ATM RFC2684 bridging utility
 endef
 
 define Build/Configure
@@ -51,22 +51,23 @@ define Package/linux-atm/install
 endef
 
 define Package/br2684ctl/install
+       install -d -m0755 $(1)/etc/hotplug.d/net
+       install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
        install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/hotplug.d/net
-       install -m0644 ./files/br2684.init $(1)/etc/hotplug.d/net/30-br2684
 endef
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/atm{,d,sap}.h $(STAGING_DIR)/usr/include/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/include/atm{,d,sap}.h \
+               $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.{a,so*} $(STAGING_DIR)/usr/lib/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libatm.{a,so*} \
+               $(STAGING_DIR)/usr/lib/
 endef
 
 define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/atm{,d,sap}.h \
+       rm -rf  $(STAGING_DIR)/usr/include/atm{,d,sap}.h \
                $(STAGING_DIR)/usr/lib/libatm.{a,so*}
 endef
 
diff --git a/openwrt/package/linux-atm/files/br2684.hotplug b/openwrt/package/linux-atm/files/br2684.hotplug
new file mode 100644 (file)
index 0000000..242e7e5
--- /dev/null
@@ -0,0 +1,19 @@
+[ "${INTERFACE%%[0-9]*}" = "atm" ] && {
+       case "$ACTION" in
+               register)
+                       [ "$pppoe_atm" = 1 ] && {
+                               case "$atm_encaps" in
+                                       0|vc) ENCAPS=0 ;;
+                                       1|llc) ENCAPS=1 ;;
+                                       *) ENCAPS=0 ;;
+                               esac
+                               insmod br2684 2>&- >&-
+                               br2684ctl -c0 -e${ENCAPS} -a${atm_vpi:-8}.${atm_vci:-35} &
+                       }
+               ;;
+               unregister)
+                       killall br2684ctl 2>&- >&-
+                       rmmod br2684
+               ;;
+       esac
+}
diff --git a/openwrt/package/linux-atm/files/br2684.init b/openwrt/package/linux-atm/files/br2684.init
deleted file mode 100644 (file)
index 242e7e5..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-[ "${INTERFACE%%[0-9]*}" = "atm" ] && {
-       case "$ACTION" in
-               register)
-                       [ "$pppoe_atm" = 1 ] && {
-                               case "$atm_encaps" in
-                                       0|vc) ENCAPS=0 ;;
-                                       1|llc) ENCAPS=1 ;;
-                                       *) ENCAPS=0 ;;
-                               esac
-                               insmod br2684 2>&- >&-
-                               br2684ctl -c0 -e${ENCAPS} -a${atm_vpi:-8}.${atm_vci:-35} &
-                       }
-               ;;
-               unregister)
-                       killall br2684ctl 2>&- >&-
-                       rmmod br2684
-               ;;
-       esac
-}