build: ensure that package/host-build build system code does not run in parallel...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 17 Sep 2012 11:17:26 +0000 (11:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 17 Sep 2012 11:17:26 +0000 (11:17 +0000)
SVN-Revision: 33445

include/host-build.mk
include/package.mk

index 06f93a14ade8d36000eabbf963b7296f18ff3de4..e011c1548011f84d18178fff94fece011e762d23 100644 (file)
@@ -136,6 +136,8 @@ define Host/Exports/Default
 endef
 Host/Exports=$(Host/Exports/Default)
 
+.NOTPARALLEL:
+
 ifndef DUMP
   define HostBuild
   $(if $(HOST_QUILT),$(Host/Quilt))
index e93aebf67db18424a9158ac970b40dc2175d2c2f..3ec5ffdadd3d7c711e044118b14616122427ec11 100644 (file)
@@ -248,6 +248,8 @@ Build/Install=$(if $(PKG_INSTALL),$(call Build/Install/Default,))
 Build/Dist=$(call Build/Dist/Default,)
 Build/DistCheck=$(call Build/DistCheck/Default,)
 
+.NOTPARALLEL:
+
 $(PACKAGE_DIR):
        mkdir -p $@