more fixes
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 23:04:46 +0000 (23:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 23:04:46 +0000 (23:04 +0000)
SVN-Revision: 5048

openwrt/include/kernel-build.mk
openwrt/rules.mk

index 6aefe0b891d8d914a0c2350055f1199fdd5f55fd..5544a82e37f50f213fdd9ad1c109dd9bf0d7be3e 100644 (file)
@@ -4,6 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+include $(INCLUDE_DIR)/host.mk
 -include $(INCLUDE_DIR)/modules-$(KERNEL).mk
 
 LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
index b9859dbd3f66e9b653e56331a9ed05319d8fc341..be269e77f33c9b308bc5bd01c255411e99ab21d0 100644 (file)
@@ -84,6 +84,7 @@ RSTRIP:= \
 
 # where to build (and put) .ipk packages
 IPKG:= \
+  PATH="$(STAGING_DIR)/bin:$(PATH)" \
   IPKG_TMP=$(BUILD_DIR)/tmp \
   IPKG_INSTROOT=$(TARGET_DIR) \
   IPKG_CONF_DIR=$(STAGING_DIR)/etc \