firewall: allow incoming udp/68 packets in the default configuration (#4108, #4781)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Aug 2009 03:31:53 +0000 (03:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 13 Aug 2009 03:31:53 +0000 (03:31 +0000)
SVN-Revision: 17238

package/firewall/Makefile
package/firewall/files/firewall.config

index 7dcc2f573968b38aeff3abe3434ef54e1ee4af7d..0f1b1118d7a1a4bd8556dec1f65c544df936f7b3 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 
index 464540f9901cab71e2a49bc3fdbb72d14446ff6c..5a4b5af43657d3508e582b2bacea8893941d12c2 100644 (file)
@@ -22,6 +22,14 @@ config forwarding
        option dest     wan
        option mtu_fix  1
 
+# We need to accept udp packets on port 68,
+# see https://dev.openwrt.org/ticket/4108
+config rule
+       option src              wan
+       option proto            udp
+       option dest_port        68
+       option target           ACCEPT
+
 # include a file with users custom iptables rules
 config include
        option path /etc/firewall.user