hide experimental/developer options from the user. can be reenabled by using make...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 5 Apr 2005 18:21:58 +0000 (18:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 5 Apr 2005 18:21:58 +0000 (18:21 +0000)
SVN-Revision: 567

openwrt/Config.in
openwrt/Config.in.devel [new file with mode: 0644]
openwrt/Makefile
openwrt/package/busybox/Config.in
openwrt/toolchain/Config.in
openwrt/toolchain/Config.in.devel [new file with mode: 0644]
openwrt/toolchain/binutils/Config.in
openwrt/toolchain/ccache/Config.in
openwrt/toolchain/gcc/Config.in
openwrt/toolchain/uClibc/Config.in

index 31ddbac6d736001ef987b769b02348a185529660..576e4826da14dfb75660cae89f4dcd69d5a85c0b 100644 (file)
@@ -11,7 +11,6 @@ config BR2_HAVE_DOT_CONFIG
        default y
 
 choice
-       prompt "Target Architecture"
        default BR2_mipsel
        help
          Stuff
@@ -65,7 +64,7 @@ config BR2_ARCH
        default "i386"    if BR2_i386
        default "m68k"    if BR2_m68k
        default "mips"    if BR2_mips
-       default "mipsel"  if BR2_mipsel
+       default "mipsel"  if BR2_mipsel || !CONFIG_DEVEL
        default "powerpc" if BR2_powerpc
        default "sh3"     if BR2_sh3
        default "sh3eb"   if BR2_sh3eb
@@ -74,36 +73,21 @@ config BR2_ARCH
        default "sparc"   if BR2_sparc
 
 
-menu "Build options"
-
 config BR2_WGET
-       string "Wget command"
+       string 
        default "wget --passive-ftp -nd"
 
 config BR2_TAR_VERBOSITY
-       bool "Tar verbose"
+       bool 
        default n
 
 config BR2_STAGING_DIR
-       string "Toolchain and header file location?"
+       string
        default "$(BASE_DIR)/staging_dir_$(ARCH)$(ARCH_FPU_SUFFIX)"
-       help
-           This is the location where the toolchain will be installed.
-           Since the toolchain will not work if it is moved from this
-           location, it is important for people wishing to package up
-           a uClibc toolchain that this be set to the location in which
-           the toolchain will be used.
-
-           Most people will leave this set to the default value of
-           "$(BASE_DIR)/staging_dir_$(ARCH)$(ARCH_FPU_SUFFIX)".
 
 config BR2_JLEVEL
-       int "Number of jobs to run simultaneously"
+       int
        default "1"
-       help
-           Number of jobs to run simultanesouly
-
-endmenu
 
 source "toolchain/Config.in"
 source "package/Config.in"
diff --git a/openwrt/Config.in.devel b/openwrt/Config.in.devel
new file mode 100644 (file)
index 0000000..38e79b9
--- /dev/null
@@ -0,0 +1,114 @@
+#
+
+mainmenu "OpenWRT Configuration"
+
+config MODULES
+       bool
+       default y
+
+config BR2_HAVE_DOT_CONFIG
+       bool
+       default y
+
+config CONFIG_DEVEL
+       bool
+       default y
+
+choice
+       prompt "Target Architecture" if CONFIG_DEVEL
+       default BR2_mipsel
+       help
+         Stuff
+
+config BR2_arm
+       bool "arm"
+
+config BR2_armeb
+       bool "armeb"
+
+config BR2_cris
+       bool "cris"
+
+config BR2_i386
+       bool "i386"
+
+config BR2_m68k
+       bool "m68k"
+
+config BR2_mips
+       bool "mips"
+
+config BR2_mipsel
+       bool "mipsel"
+
+config BR2_powerpc
+       bool "powerpc"
+
+config BR2_sh3
+       bool "sh3"
+
+config BR2_sh3eb
+       bool "sh3eb"
+
+config BR2_sh4
+       bool "sh4"
+
+config BR2_sh4eb
+       bool "sh4eb"
+
+config BR2_sparc
+       bool "sparc"
+
+endchoice
+
+config BR2_ARCH
+       string
+       default "arm"     if BR2_arm
+       default "armeb"   if BR2_armeb
+       default "cris"    if BR2_cris
+       default "i386"    if BR2_i386
+       default "m68k"    if BR2_m68k
+       default "mips"    if BR2_mips
+       default "mipsel"  if BR2_mipsel
+       default "powerpc" if BR2_powerpc
+       default "sh3"     if BR2_sh3
+       default "sh3eb"   if BR2_sh3eb
+       default "sh4"     if BR2_sh4
+       default "sh4eb"   if BR2_sh4eb
+       default "sparc"   if BR2_sparc
+
+
+menu "Build options"
+
+config BR2_WGET
+       string "Wget command"
+       default "wget --passive-ftp -nd"
+
+config BR2_TAR_VERBOSITY
+       bool "Tar verbose"
+       default n
+
+config BR2_STAGING_DIR
+       string "Toolchain and header file location?"
+       default "$(BASE_DIR)/staging_dir_$(ARCH)$(ARCH_FPU_SUFFIX)"
+       help
+           This is the location where the toolchain will be installed.
+           Since the toolchain will not work if it is moved from this
+           location, it is important for people wishing to package up
+           a uClibc toolchain that this be set to the location in which
+           the toolchain will be used.
+
+           Most people will leave this set to the default value of
+           "$(BASE_DIR)/staging_dir_$(ARCH)$(ARCH_FPU_SUFFIX)".
+
+config BR2_JLEVEL
+       int "Number of jobs to run simultaneously"
+       default "1"
+       help
+           Number of jobs to run simultanesouly
+
+endmenu
+
+source "toolchain/Config.in.devel"
+source "package/Config.in"
+source "target/Config.in"
index 3d9bcb3870677a2ecc98cf3fc91e4ec64a631637..fd2a4ad8e49e228c6501cadba0fe23d65973a4b3 100644 (file)
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+ifneq ($(DEVELOPER),)
+CONFIG_CONFIG_IN = Config.in.devel
+else
 CONFIG_CONFIG_IN = Config.in
+endif
 CONFIG_DEFCONFIG = .defconfig
 CONFIG = package/config
 
index 4f72994af54d1e745c0cc127f5c475c53f899e61..4187ed0bef9972415e42838a98f4a20f04d20160 100644 (file)
@@ -12,6 +12,7 @@ config BR2_PACKAGE_BUSYBOX
 config BR2_PACKAGE_BUSYBOX_SNAPSHOT
        bool "Use the daily snapshot of busybox?"
        depends BR2_PACKAGE_BUSYBOX
+       depends CONFIG_DEVEL
        default n
        help
          Use the latest busybox CVS snapshot instead of release.
index 5b3fe701254ef9007a92583ed015f0072c616f66..756deddd249cca753382cffe769cb1162302dd3d 100644 (file)
@@ -1,56 +1,29 @@
 #
 
-menu "Toolchain Options"
-
-
 source "toolchain/uClibc/Config.in"
 source "toolchain/binutils/Config.in"
 source "toolchain/gcc/Config.in"
 source "toolchain/ccache/Config.in"
 
-
-comment "Common Toolchain Options"
+if CONFIG_DEVEL
+       comment "Common Toolchain Options"
+endif
 
 config BR2_ENABLE_MULTILIB
-       bool "Enable multilib support?"
+       bool
        default n
-       help
-           If you want multilib enabled, enable this...
 
 config BR2_LARGEFILE
-       bool "Enable large file (files > 2 GB) support?"
+       bool
        depends on !BR2_cris
        default y
-       help
-           Enable large file (files > 2 GB) support
 
 config BR2_SOFT_FLOAT
-       bool "Use software floating point by default"
+       bool
        default n
        depends on BR2_arm || BR2_mips || BR2_powerpc
-       help
-         If your target CPU does not have a Floating Point Unit (FPU) or a
-         kernel FPU emulator, but you still wish to support floating point
-         functions, then everything will need to be compiled with soft floating
-         point support (-msoft-float).
-
-         Most people will answer N.
 
 config BR2_TARGET_OPTIMIZATION
-       string "Target Optimizations"
+       string
        default "-Os -pipe -mips32 -mtune=mips32"
-       help
-         Optimizations to use when building for the target host.
-
-# Might be worth experimenting with for gcc 3.4.x.
-#GCC_WITH_CPU:=
-#GCC_WITH_ARCH:=
-#GCC_WITH_TUNE:=
-
-#GCC_WITH_CPU:=--with-cpu=
-#GCC_WITH_ARCH:=--with-arch=
-#GCC_WITH_TUNE:=--with-tune=
-
-
-endmenu
 
diff --git a/openwrt/toolchain/Config.in.devel b/openwrt/toolchain/Config.in.devel
new file mode 100644 (file)
index 0000000..0043460
--- /dev/null
@@ -0,0 +1,55 @@
+#
+
+menu "Toolchain Options"
+
+source "toolchain/uClibc/Config.in"
+source "toolchain/binutils/Config.in"
+source "toolchain/gcc/Config.in"
+source "toolchain/ccache/Config.in"
+
+
+comment "Common Toolchain Options"
+
+config BR2_ENABLE_MULTILIB
+       bool "Enable multilib support?"
+       default n
+       help
+           If you want multilib enabled, enable this...
+
+config BR2_LARGEFILE
+       bool "Enable large file (files > 2 GB) support?"
+       depends on !BR2_cris
+       default y
+       help
+           Enable large file (files > 2 GB) support
+
+config BR2_SOFT_FLOAT
+       bool "Use software floating point by default"
+       default n
+       depends on BR2_arm || BR2_mips || BR2_powerpc
+       help
+         If your target CPU does not have a Floating Point Unit (FPU) or a
+         kernel FPU emulator, but you still wish to support floating point
+         functions, then everything will need to be compiled with soft floating
+         point support (-msoft-float).
+
+         Most people will answer N.
+
+config BR2_TARGET_OPTIMIZATION
+       string "Target Optimizations"
+       default "-Os -pipe -mips32 -mtune=mips32"
+       help
+         Optimizations to use when building for the target host.
+
+# Might be worth experimenting with for gcc 3.4.x.
+#GCC_WITH_CPU:=
+#GCC_WITH_ARCH:=
+#GCC_WITH_TUNE:=
+
+#GCC_WITH_CPU:=--with-cpu=
+#GCC_WITH_ARCH:=--with-arch=
+#GCC_WITH_TUNE:=--with-tune=
+
+
+endmenu
+
index 4b06f1aa9af19c06bddde5a9a4d598b90e638253..3fe1750a42865b3214482497e2be2602685ed902 100644 (file)
@@ -1,9 +1,11 @@
 # Choose binutils version.
 
-comment "Binutils Options"
+if CONFIG_DEVEL
+       comment "Binutils Options"
+endif
 
 choice
-       prompt "Binutils Version"
+       prompt "Binutils Version" if CONFIG_DEVEL
        default BR2_BINUTILS_VERSION_2_14_90_0_8
        help
          Select the version of binutils you wish to use.
@@ -56,7 +58,7 @@ config BR2_BINUTILS_VERSION
        string
        default "2.14.90.0.6"     if BR2_BINUTILS_VERSION_2_14_90_0_6
        default "2.14.90.0.7"     if BR2_BINUTILS_VERSION_2_14_90_0_7
-       default "2.14.90.0.8"     if BR2_BINUTILS_VERSION_2_14_90_0_8
+       default "2.14.90.0.8"     if BR2_BINUTILS_VERSION_2_14_90_0_8 || !CONFIG_DEVEL
        default "2.15"            if BR2_BINUTILS_VERSION_2_15
        default "2.15.90.0.1"     if BR2_BINUTILS_VERSION_2_15_90_0_1
        default "2.15.90.0.0.1.1" if BR2_BINUTILS_VERSION_2_15_90_0_1_1
index a265375c405241ab0a983c7912dcf22693be7dbe..9cd6f0b11d60a7f4d29d7519afde9c37dde4a110 100644 (file)
@@ -1,9 +1,10 @@
 #
-
-comment "Ccache Options"
+if CONFIG_DEVEL
+       comment "Ccache Options"
+endif
 
 config BR2_CCACHE
-       bool "Enable ccache support?"
+       bool "Enable ccache support?" if CONFIG_DEVEL
        default y
        help
            Enable ccache support?
index 9dd7d0ca4172921a1fd495c5d72ea23b780e6fe7..7d70d0691cb8bae8f3c1b84a05a01afab16c29e7 100644 (file)
@@ -2,10 +2,12 @@
 # WARNING -- 2.95 currently only builds for i386, arm, mips*, and powerpc.
 # WARNING -- 2.95 does not currently build natively for the target.
 
-comment "Gcc Options"
+if CONFIG_DEVEL
+       comment "Gcc Options"
+endif
 
 choice
-       prompt "GCC compiler Version"
+       prompt "GCC compiler Version" if CONFIG_DEVEL
        default BR2_GCC_VERSION_3_3_5
        help
          Select the version of gcc you wish to use.
@@ -35,10 +37,9 @@ endchoice
 
 config BR2_GCC_VERSION
        string
-       default "2.95"      if BR2_GCC_VERSION_2_95
        default "3.3.3"     if BR2_GCC_VERSION_3_3_3
        default "3.3.4"     if BR2_GCC_VERSION_3_3_4
-       default "3.3.5"     if BR2_GCC_VERSION_3_3_5
+       default "3.3.5"     if BR2_GCC_VERSION_3_3_5 || !CONFIG_DEVEL
        default "3.4.0"     if BR2_GCC_VERSION_3_4_0
        default "3.4.1"     if BR2_GCC_VERSION_3_4_1
        default "3.4.2"     if BR2_GCC_VERSION_3_4_2
@@ -53,13 +54,15 @@ config BR2_GCC_USE_SJLJ_EXCEPTIONS
            but not dynamic.  So use setjmp/longjmp exceptions by default.
 
 config BR2_EXTRA_GCC_CONFIG_OPTIONS
-       string "Additional gcc options"
+       string
+       prompt "Additional gcc options" if CONFIG_DEVEL
        default ""
        help
            Any additional gcc options you may want to include....
 
 config BR2_INSTALL_LIBSTDCPP
-       bool "Build/install c++ compiler and libstdc++?"
+       bool
+       prompt "Build/install c++ compiler and libstdc++?" if CONFIG_DEVEL
        default n
        help
            Build/install c++ compiler and libstdc++?
index 0e4b29a7df5170320c8ebe5fa3b1fe89b1f0d788..09453bff3e5f351fa6d2ceb1ba87a4d6ede94560 100644 (file)
@@ -1,10 +1,12 @@
 # Choose uClibc options
 #
-
-comment "uClibc Options"
+if CONFIG_DEVEL
+       comment "uClibc Options"
+endif
 
 config BR2_UCLIBC_VERSION_SNAPSHOT
-       bool "Use the daily snapshot of uClibc?"
+       bool
+       prompt "Use the daily snapshot of uClibc?" if CONFIG_DEVEL
        default n
        help
            Would you like to use the latest daily snapshot?
@@ -15,7 +17,8 @@ config BR2_USE_UCLIBC_SNAPSHOT
        depends on BR2_UCLIBC_VERSION_SNAPSHOT
 
 config BR2_ENABLE_LOCALE
-       bool "Enable locale/gettext/i18n support?"
+       bool
+       prompt "Enable locale/gettext/i18n support?" if CONFIG_DEVEL
        default n
        help
            Enable locale/gettext/i18n support?