hide .host.mk commands
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:04:17 +0000 (17:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:04:17 +0000 (17:04 +0000)
SVN-Revision: 5023

openwrt/include/host.mk

index 64588814726953c0d9763dc248e35c41f81d934b..93f86dce8aafbdc5a3a379455787a657188bc97d 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/.host.mk
 
 $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-       echo "HOST_OS:=`uname`" > $@
-       echo "HOST_ARCH:=` \
+       @echo "HOST_OS:=`uname`" > $@
+       @echo "HOST_ARCH:=` \
                $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
                        -e 's/sparc.*/sparc/' \
                        -e 's/arm.*/arm/' \
@@ -21,8 +21,8 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                        -e 's/mipsel-.*/mipsel/' \
                        -e 's/cris.*/cris/' \
                        -e 's/i[3-9]86/i386/'`" >> $@
-       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
-       if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+       @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+       @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
                echo "TAR_OPTIONS+=--wildcards" >> $@; \
        fi