kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
authorJohn Crispin <john@openwrt.org>
Sun, 20 Jul 2014 17:31:11 +0000 (17:31 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 20 Jul 2014 17:31:11 +0000 (17:31 +0000)
SVN-Revision: 41776

29 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.10/104-watchdog-ath79-wdt-avoid-spurious-restarts-on-AR934x.patch [deleted file]
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/sparc/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile
target/linux/xburst/Makefile

index c40aacb84af0f2ec6c55dd4fccc02919eaa15649..08a4c6ddd97398984bad7638124b9286a5f5acce 100644 (file)
@@ -14,8 +14,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.44)
-  LINUX_KERNEL_MD5SUM:=8a4006eff3bbd8aff58fe4b443223e7a
+ifeq ($(LINUX_VERSION),3.10.49)
+  LINUX_KERNEL_MD5SUM:=9774e12764e740d49c80eda77d0ef3eb
 endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
index 0d92295896079ed2b1c9cc7596f6bed60c7531a8..3f40e57837a703f0e2423fa3101d681a8839ed53 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm low_mem
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index b2a16f91258f396a2f05b7edd4802fbabe96c309..1b400745d1b5c4bc777e3342ebccb3a687154267 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ar71xx/patches-3.10/104-watchdog-ath79-wdt-avoid-spurious-restarts-on-AR934x.patch b/target/linux/ar71xx/patches-3.10/104-watchdog-ath79-wdt-avoid-spurious-restarts-on-AR934x.patch
deleted file mode 100644 (file)
index c7bf066..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From 2ff030d44672d745c5327b72463af43f5103e99b Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Tue, 25 Mar 2014 17:07:46 +0100
-Subject: [PATCH] watchdog: ath79-wdt: avoid spurious restarts on AR934x
-
-On some AR934x based systems, where the frequency of
-the AHB bus is relatively high, the built-in watchdog
-causes a spurious restart when it gets enabled.
-
-The possible cause of these restarts is that the timeout
-value written into the TIMER register does not reaches
-the hardware in time.
-
-Add an explicit delay into the ath79_wdt_enable function
-to avoid the spurious restarts.
-
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
-Cc: <stable@vger.kernel.org>
----
- drivers/watchdog/ath79_wdt.c |   10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/drivers/watchdog/ath79_wdt.c
-+++ b/drivers/watchdog/ath79_wdt.c
-@@ -20,6 +20,7 @@
- #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
- #include <linux/bitops.h>
-+#include <linux/delay.h>
- #include <linux/errno.h>
- #include <linux/fs.h>
- #include <linux/init.h>
-@@ -91,6 +92,15 @@ static inline void ath79_wdt_keepalive(v
- static inline void ath79_wdt_enable(void)
- {
-       ath79_wdt_keepalive();
-+
-+      /*
-+       * Updating the TIMER register requires a few microseconds
-+       * on the AR934x SoCs at least. Use a small delay to ensure
-+       * that the TIMER register is updated within the hardware
-+       * before enabling the watchdog.
-+       */
-+      udelay(2);
-+
-       ath79_wdt_wr(WDOG_REG_CTRL, WDOG_CTRL_ACTION_FCR);
-       /* flush write */
-       ath79_wdt_rr(WDOG_REG_CTRL);
index feb800dc0bb05d7542d681d88e49afa5e8a059cc..01fc4dd85f9080a4827b1865552218660333a3e7 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
 CPU_TYPE:=arm926ej-s
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index eba9f77715d0d983ec5b146174c8b39dd3f929b1..1b52909476d5d534f8157e0b86d2e270e3bbc961 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 5fb4a436fbc0e7e072d29f11f3bbdfcf1e36e573..9a2e4f5fae1d29f87ad95bb1565a32912259d00e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index da5d541d96fa983a53d8f37b3da1380d4a902e04..de5410309e25a2c6b2dfef4e8bbb9b956ff30732 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 1c6a916078f72ba8582303af6194cd70fd459882..679997c0a7ecf2ec3abcd37330380af215340fe1 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index abeedb3b47fd6616a240711588099a214ee51c8e..afb62016e1385a89bc36d496c6be85330b9a0476 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 4d96a1dd85856c4f73da2fc12833980a5eac97b0..795b85840400f325aad1044b7c4f7bf9d8093eef 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb
 SUBTARGETS:=generic mips74k legacy
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 02596a138f719a1a8adace851d67fe3c23192a7a..4a74e96c03b2e14d324e89741b3455efa940d731 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia usbgadget
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 2b0d7f2edf3e01c79a702d26eb966edabcb3ab29..4f320b2f29a04185944f2801bccbfefc2100d0aa 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 4e55a76bb5e1cedc5ed5c4926f49844b52b2f1a3..544c757a567c6bd19d39b7d96544edce329963a0 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 36d3bf2cd20987861128ee03b3fa6e5d97c356db..b0665db0510c86ece725547b85f6097bc250dbfa 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index d1573b06b5a57cb4337eddf767ed4d137341b621..65c6e5ee28a3bd95c3c614eb5f4e9b8e32984c11 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand nand ubifs
 CPU_TYPE:=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 32bec5e663003a9b5795eb2bb6e2fad4349a3250..143c11066418298f1d0d7cb60118b2375b010465 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq
 FEATURES:=squashfs
 SUBTARGETS=xway xrx200
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 CPU_TYPE:=mips32r2
 
index 92bd3e4b1ae52df6b6121dacd2777eb99624897a..e5b16b2bdcd5283ea1394f2773fb643979fe76cb 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 DEVICE_TYPE:=developerboard
 
index f829df58927f78ccf522f245aa69773ba6a2acee..37669684db1c5005a7d5d2846ffce7b3233ab8a6 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 13cbe716e5c1e0d627e7208873b5ba13b0320f24..5138325de92352a08c863c8ad4a9683571735834 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon -mabi=64
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index 9e7e5d8cf03752e015a6b85abfbe3345612dc1a2..817abc7f49a7be5a0faf7c7f36b3f928a4ff8b05 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index f84aa0435fc4226ae2e1e151847a165a3eaf5b05..f6d932743a0b0112862a934ddf70114de1cb0b9c 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index c9551d8d81939f971b91b0b77d8c86dad1156283..d363743fc258c10b73f004736f2c55e2175fc5cc 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
index a98404d737cb12773051d14e48b3ca4c68390eed..3fda24b6f09c4885ed99dfd611ec5c656d4a3ea9 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index fb5b9f264a20466f01821c9e04f46e3ca7f75c8a..3d49605130817c9fd7a007a22774d201f894909a 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 DEVICE_TYPE:=developerboard
 
index 2e7083999ce877cb60d162a44892cc9ae9e02a16..0fee7c17ebc428e568071780f3e792f90f8edfd3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sparc
 BOARDNAME:=Sun UltraSPARC
 FEATURES+=fpu tgz ext4 squashfs broken
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 6c552e149e6b30e6c3f6c445e2e701ff6b6af9d3..5f4896c5d43f77aadb62891a90c2a0cc9afadd09 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
index b889de87b0bbea9a0ba233f4647c7f04e7ba797c..32eafdfc0a50afacf760b63aa939c24f532536b0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
           rdc
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 KERNELNAME:=bzImage
 
index 007e3edb2c462d7eecdccc21b4a477330087ce99..92897393d69683a17592c28a60853ab3c11cd2b0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz nand ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.44
+LINUX_VERSION:=3.10.49
 
 DEVICE_TYPE=other