kernel: add kmod-fb-tft-ili9486
authorStijn Tintel <stijn@linux-ipv6.be>
Sat, 9 Feb 2019 17:01:28 +0000 (19:01 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Sat, 23 Feb 2019 23:15:22 +0000 (01:15 +0200)
This module adds support for the ILI9486 LCD controller used in devices
like the Waveshare 3.5" and 4" LCD displays designed for Raspberry Pi.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/video.mk

index ee58e97b34ccedc46b45bff5283dc080a31b8e37..f11431dc2d51659b23aaa2ec5adb32edf1e35f75 100644 (file)
@@ -205,6 +205,22 @@ endef
 $(eval $(call KernelPackage,fb-tft))
 
 
+define KernelPackage/fb-tft-ili9486
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=FB driver for the ILI9486 LCD Controller
+  DEPENDS:=+kmod-fb-tft
+  KCONFIG:=CONFIG_FB_TFT_ILI9486
+  FILES:=$(LINUX_DIR)/drivers/staging/fbtft/fb_ili9486.ko
+  AUTOLOAD:=$(call AutoLoad,09,fb_ili9486)
+endef
+
+define KernelPackage/fb-tft-ili9486/description
+  FB driver for the ILI9486 LCD Controller
+endef
+
+$(eval $(call KernelPackage,fb-tft-ili9486))
+
+
 define KernelPackage/drm
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Direct Rendering Manager (DRM) support