ubox: update to latest git head
authorJohn Crispin <john@openwrt.org>
Tue, 18 Mar 2014 19:22:38 +0000 (19:22 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 18 Mar 2014 19:22:38 +0000 (19:22 +0000)
logread now shows the right time.

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 39951

package/system/ubox/Makefile
package/system/ubox/files/log.init

index 08da9d0dda65f2ff86c3ed132d9c68b405878118..09bbc0933c30ec2fe38f9ac7214b7f2286c564bd 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_VERSION:=2014-03-12
+PKG_VERSION:=2014-03-18
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c8d14b9b5d0fa3a3f99df386b67670e083c82095
+PKG_SOURCE_VERSION:=1015c3779f37a17c6a2512bfc817e56d3042a237
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
index ca29fd882cc37ecb918a029144f85bfda260d7b2..e11a74b57238e9f5930be4122a6a487a9ffa5127 100644 (file)
@@ -24,14 +24,17 @@ validate_log_section()
 validate_log_daemon()
 {
        uci_validate_section system system "${1}" \
-               'log_buffer_size:uinteger:16'
+               'log_size:uinteger:0' \
+               'log_buffer_size:uinteger:0'
        return $?
 }
 
 start_service_daemon()
 {
-       local log_buffer_size
+       local log_buffer_size log_size
        validate_log_daemon "${1}"
+       [ $log_buffer_size -eq 0 -a $log_size -gt 0 ] && log_buffer_size=$log_size
+       [ $log_buffer_size -eq 0 ] && log_buffer_size=16
        procd_open_instance
        procd_set_param command "/sbin/logd"
        procd_append_param command -S "${log_buffer_size}"