Revert "mt76: probe load mt7615 driver asynchronously"
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Mon, 14 Oct 2019 07:48:32 +0000 (15:48 +0800)
committerPetr Štetiar <ynezz@true.cz>
Fri, 29 Nov 2019 23:53:36 +0000 (00:53 +0100)
This reverts commit 81764319637f ("mt76: probe load mt7615 driver
asynchronously").  After said commit, users report that MT7615 no longer
works on boot and they have to manually enable WiFi (via command "wifi") to
make it working again.

Fixes: FS#2546
Ref: https://forum.openwrt.org/t/xiaomi-r3p-no-wifi-on-boot/45509
Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
[commit description facelift]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/kernel/mt76/Makefile

index ce2bf8f14bdfe87a0d5073100ceb60c6ea2a8aaa..04c1761d8824ef8262d9917e756da3a9b2a63b92 100644 (file)
@@ -144,7 +144,6 @@ define KernelPackage/mt7615e
   DEPENDS+=@PCI_SUPPORT +kmod-mt76-core
   FILES:=\
        $(PKG_BUILD_DIR)/mt7615/mt7615e.ko
-  MODPARAMS:=async_probe
   AUTOLOAD:=$(call AutoProbe,mt7615e)
 endef