ramips: Add support for the Netgear WNDR3700v5
authorJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:43:53 +0000 (11:43 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:43:53 +0000 (11:43 +0000)
https://wiki.openwrt.org/toh/netgear/wndr3700

wndr3700v5 uses the single-core dual thread MediaTek MT7621S SoC.

Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
SVN-Revision: 49247

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/WNDR3700V5.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/profiles/netgear.mk [new file with mode: 0644]

index a263b524a2a75e68ff2588fa160a0c468014b3db..aeaab3395a6c6f67f64d521cf0d83cde43926af3 100755 (executable)
@@ -271,6 +271,9 @@ wrh-300cr)
        set_wifi_led "$board:green:wlan"
        ucidef_set_led_netdev "lan" "lan" "$board:green:ethernet" "eth0"
        ;;
+wndr3700v5)
+       ucidef_set_led_default "power" "POWER" "$board:green:power" "0"
+       ;;
 wt3020)
        ucidef_set_led_default "power" "power" "$board:blue:power" "0"
        ;;
index 28fcc61352d6489d8a54248a341afd15c7bfbf71..c6c740f62382563b39793128aa523cad544ff432 100755 (executable)
@@ -81,6 +81,7 @@ ramips_setup_interfaces()
        whr-300hp2|\
        whr-600d|\
        witi|\
+       wndr3700v5|\
        wsr-1166|\
        wsr-600|\
        wt1520|\
index 352357c6cde044f19bf466e55063655b23cce01b..20ff8fff38ff5223bae3c93a466e0c363a33154c 100644 (file)
@@ -27,6 +27,7 @@ get_status_led() {
        nbg-419n|\
        pwh2004|\
        wnce2001|\
+       wndr3700v5|\
        x5|\
        x8|\
        xdxrn502j)
index 13d325dbbca7c593b76a674e8dcd75d0f627e081..2c669c5a5bf7c48d5532a86024a53afe10db83c7 100755 (executable)
@@ -460,6 +460,9 @@ ramips_board_detect() {
        *"WNCE2001")
                name="wnce2001"
                ;;
+       *"WNDR3700v5")
+               name="wndr3700v5"
+               ;;
        *"WR512-3GN-like"*)
                name="wr512-3gn"
                ;;
index 522e78a60403ed0b4ca2ef87ebbf0e0e890f7015..2b24030ecd4bffe52f1dfad817b34c77b70c7d2e 100755 (executable)
@@ -136,6 +136,7 @@ platform_check_image() {
        wli-tx4-ag300n|\
        wmr-300|\
        wnce2001|\
+       wndr3700v5|\
        wr512-3gn|\
        wr6202|\
        wrh-300cr|\
diff --git a/target/linux/ramips/dts/WNDR3700V5.dts b/target/linux/ramips/dts/WNDR3700V5.dts
new file mode 100644 (file)
index 0000000..7b20849
--- /dev/null
@@ -0,0 +1,139 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+/ {
+       compatible = "mediatek,mt7621-eval-board","ralink,mt7621-soc";
+       model = "Netgear WNDR3700v5";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x8000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600 maxcpus=2";
+       };
+
+       palmbus@1E000000 {
+               spi@b00 {
+                       status = "okay";
+
+               m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l12805d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@f30000 {
+                                       label = "factory";
+                                       reg = <0xf30000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       pcie@1e140000 {
+               status = "okay";
+
+               pcie0 {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x0004>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+
+               pcie2 {
+                       mt76@2,0 {
+                               reg = <0x1000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8004>;
+                               mediatek,5ghz = <0>;
+                       };
+               };
+       };
+
+       ethernet@1e100000 {
+               mtd-mac-address = <&factory 0x0000000c>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group =  "rgmii2", "mdio", "wdt";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wps {
+                       label = "wndr3700v5:green:wps";
+                       gpios = <&gpio0 12 1>;
+               };
+
+               power {
+                       label = "wndr3700v5:green:power";
+                       gpios = <&gpio0 18 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wps {
+                       label = "wndr3700v5:wps";
+                       gpios = <&gpio0 7 0>;
+                       linux,code = <0x211>;
+               };
+
+               wifi {
+                       label = "wndr3700v5:wifi";
+                       gpios = <&gpio0 8 0>;
+                       linux,code = <0xf7>;
+               };
+
+               reset {
+                       label = "wndr3700v5:reset";
+                       gpios = <&gpio0 14 0>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usbpower {
+                       gpio-export,name = "usbpower";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 10 1>;
+               };
+       };
+};
index 0af9596e5ee319f09384de34116c5ac73bb26ae7..1b8d3dae87510a7660e9c570fd1c74462a977c26 100644 (file)
@@ -97,6 +97,12 @@ define Device/witi
 endef
 TARGET_DEVICES += witi
 
+define Device/wndr3700v5
+  DTS := WNDR3700V5
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+TARGET_DEVICES += wndr3700v5
+
 define Device/zbt-wg2626
   DTS := ZBT-WG2626
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
diff --git a/target/linux/ramips/mt7621/profiles/netgear.mk b/target/linux/ramips/mt7621/profiles/netgear.mk
new file mode 100644 (file)
index 0000000..05802a2
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDR3700V5
+       NAME:=Netgear WNDR3700v5
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3
+endef
+
+define Profile/WNDR3700V5/Description
+       Package set compatible with the Netgear WNDR3700v5.
+endef
+$(eval $(call Profile,WNDR3700V5))