lldpd: update to 1.0.3
authorLucian Cristian <lucian.cristian@gmail.com>
Tue, 30 Apr 2019 14:32:47 +0000 (17:32 +0300)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 11 May 2019 14:37:11 +0000 (16:37 +0200)
Support for CDP PD PoE

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
package/network/services/lldpd/Makefile
package/network/services/lldpd/patches/001-disable_libcap.patch [new file with mode: 0644]

index 801a772..5b36155 100644 (file)
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=1.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
-PKG_HASH:=450b622aac7ae1758f1ef82f3b7b94ec47f2ff33abfb0e6ac82555b9ee55f151
+PKG_HASH:=39fced395168015416bfe78b95414facf066f841f349024433aa20ab54e4c360
 
 PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
 PKG_LICENSE:=ISC
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -95,6 +96,7 @@ CONFIGURE_ARGS += \
        --with-embedded-libevent=no \
        --disable-hardening \
        --without-xml \
+       --disable-doxygen-doc \
        --sysconfdir=/tmp \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
@@ -104,13 +106,8 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
        $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
-       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no) \
-       $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,)
-
-# there is no flag to disable libbsd
-CONFIGURE_VARS += \
-       $(if $(CONFIG_USE_GLIBC),,libbsd_CFLAGS=-ldo-not-link-bsd) \
-       $(if $(CONFIG_USE_GLIBC),,libbsd_LDFLAGS=-ldo-not-link-bsd) \
-       $(if $(CONFIG_USE_GLIBC),,libbsd_LIBS="-lNONexistent")
+       $(if $(CONFIG_LLDPD_WITH_JSON),--enable-json0,) \
+       $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,) \
+       $(if $(CONFIG_USE_GLIBC),,--without-libbsd)
 
 $(eval $(call BuildPackage,lldpd))
diff --git a/package/network/services/lldpd/patches/001-disable_libcap.patch b/package/network/services/lldpd/patches/001-disable_libcap.patch
new file mode 100644 (file)
index 0000000..850d493
--- /dev/null
@@ -0,0 +1,17 @@
+--- a/configure.ac     2019-04-30 17:04:53.542449926 +0300
++++ b/configure.ac     2019-04-30 17:06:26.974453867 +0300
+@@ -244,7 +244,13 @@
+ # Third-party libraries
+ lldp_CHECK_LIBEVENT
+-lldp_CHECK_LIBCAP
++
++#libcap is not a core package so disable this capability
++#lldp_CHECK_LIBCAP
++libcap_LIBS=
++libcap_CFLAGS=
++AC_SUBST([libcap_LIBS])
++AC_SUBST([libcap_CFLAGS])
+ # Compatibility with pkg.m4 < 0.27
+ m4_ifdef([PKG_INSTALLDIR], [PKG_INSTALLDIR],