Disable smash stacking support by default, but allow to enable it as an experimental...
authorFlorian Fainelli <florian@openwrt.org>
Wed, 30 Jul 2008 12:54:28 +0000 (12:54 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 30 Jul 2008 12:54:28 +0000 (12:54 +0000)
SVN-Revision: 12010

package/base-files/Makefile
toolchain/gcc/Config.in
toolchain/gcc/Makefile

index 5ab776df51345f8c2e8a31b738048f1b65abd8ac..f4ef55d110e9f49b7e626be4c24f5e77a77a60d6 100644 (file)
@@ -78,6 +78,7 @@ endef
 
 define Package/libssp
 $(call Package/gcc/Default)
+  DEPENDS:=@SSP_SUPPORT
   TITLE:=GCC support library
 endef
 
index e712d5934d0e81db3c2286afa6b97f90ddd67ec4..24b86081c5b2a97ec86be78b2df15b554e34ea53 100644 (file)
@@ -53,6 +53,13 @@ config EXTRA_GCC_CONFIG_OPTIONS
        help
            Any additional gcc options you may want to include....
 
+config SSP_SUPPORT
+       bool
+       prompt "Enable Smash Stacking Protection support" if TOOLCHAINOPTS
+       default n
+       help
+           Enable Smash Stacking Protection support
+
 config INSTALL_LIBSTDCPP
        bool
        prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
index 31697989c9309044d5ae81196e5877948054c201..700463cb78a0186b8bf6bf76ae7450311305576e 100644 (file)
@@ -40,6 +40,12 @@ BUILD_DIR2:=$(BUILD_DIR_HOST)/gcc-$(PKG_VERSION)-final
 SEP:=,
 TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
 
+ifeq ($(CONFIG_SSP_SUPPORT),y)
+  SSP:=--enable-ssp
+else
+  SSP:=--disable-ssp
+endif
+
 EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-biarch --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-uclibc)
 
 define Stage1/Configure
@@ -62,6 +68,7 @@ define Stage1/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(SSP) \
                $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
@@ -96,6 +103,7 @@ define Stage2/Configure
                --disable-nls \
                --disable-libmudflap \
                --disable-multilib \
+               $(SSP) \
                $(EXTRA_TARGET) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \