kernel: bump 5.10 to 5.10.119
authorJohn Audia <therealgraysky@proton.me>
Mon, 30 May 2022 12:45:46 +0000 (08:45 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 6 Jun 2022 17:20:02 +0000 (19:20 +0200)
Delete the crypto-lib-blake2s kmod package, as BLAKE2s is now built-in.
Patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800, x86/64

Signed-off-by: John Audia <therealgraysky@proton.me>
include/kernel-5.10
package/kernel/linux/modules/crypto.mk
package/kernel/linux/modules/netsupport.mk
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/generic/config-5.10
target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
target/linux/generic/pending-5.10/205-backtrace_module_info.patch
target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch

index c05a5d842523304a360df4fdeb567e2c65881091..f12a386aa517f91cfa669052d99f02557a73486d 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .118
-LINUX_KERNEL_HASH-5.10.118 = c5e020f187a195ab0924fe7e71b8ab8fb92936ab47bc9d15e78daabddefe0b4b
+LINUX_VERSION-5.10 = .119
+LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
index cf2cf6c3ac0afcea4bfd9515e7a69bcfbd5bbb90..d43100703eb378850652e5d4f78c43dbada74eb8 100644 (file)
@@ -458,48 +458,6 @@ endef
 
 $(eval $(call KernelPackage,crypto-kpp))
 
-
-define KernelPackage/crypto-lib-blake2s
-  TITLE:=BLAKE2s hash function library
-  KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
-  HIDDEN:=1
-  FILES:=$(LINUX_DIR)/lib/crypto/libblake2s.ko
-  $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
-  imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
-  KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
-  FILES+=\
-         $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko \
-         $(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-define KernelPackage/crypto-lib-blake2s/arm
-  KCONFIG+=CONFIG_CRYPTO_BLAKE2S_ARM
-  FILES+=\
-         $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko@lt5.12 \
-         $(LINUX_DIR)/arch/arm/crypto/blake2s-arm.ko@ge5.12
-endef
-
-ifndef KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)
-  define KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)
-    KCONFIG+=CONFIG_CRYPTO_LIB_BLAKE2S_GENERIC
-    FILES+=$(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
-  endef
-endif
-
-ifdef KernelPackage/crypto-lib-blake2s/$(ARCH)
-  KernelPackage/crypto-lib-blake2s/$(CRYPTO_TARGET)=\
-         $(KernelPackage/crypto-lib-blake2s/$(ARCH))
-endif
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
 define KernelPackage/crypto-lib-chacha20
   TITLE:=ChaCha library interface
   KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA
index 76187df50fb92c67c6d00331190538457af65f66..6fb3b57e126fb7ef44d0b64faeab3973852f66e0 100644 (file)
@@ -1325,7 +1325,6 @@ define KernelPackage/wireguard
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=WireGuard secure network tunnel
   DEPENDS:= \
-         +kmod-crypto-lib-blake2s \
          +kmod-crypto-lib-chacha20poly1305 \
          +kmod-crypto-lib-curve25519 \
          +kmod-udptunnel4 \
index f2f48d654325469f3bc48b7fb2f5840d3b5da809..f66f4fc4b62d45d3882be82a029b656845cb6dde 100644 (file)
  #include <linux/types.h>
 +#include <linux/in6.h>
  
- u32 secure_ipv4_port_ephemeral(__be32 saddr, __be32 daddr, __be16 dport);
- u32 secure_ipv6_port_ephemeral(const __be32 *saddr, const __be32 *daddr,
+ u64 secure_ipv4_port_ephemeral(__be32 saddr, __be32 daddr, __be16 dport);
+ u64 secure_ipv6_port_ephemeral(const __be32 *saddr, const __be32 *daddr,
 --- a/include/uapi/linux/in.h
 +++ b/include/uapi/linux/in.h
 @@ -88,7 +88,7 @@ enum {
index 0a9d51d3f4544b42b8c684f7565cd8cb6267fe0a..9d6d44e3864db7f78c39566a72213be5061e30b9 100644 (file)
@@ -1144,7 +1144,6 @@ CONFIG_CRYPTO_KPP=y
 CONFIG_CRYPTO_KPP2=y
 CONFIG_CRYPTO_LIB_AES=y
 CONFIG_CRYPTO_LIB_ARC4=y
-# CONFIG_CRYPTO_LIB_BLAKE2S is not set
 # CONFIG_CRYPTO_LIB_CHACHA is not set
 # CONFIG_CRYPTO_LIB_CHACHA20POLY1305 is not set
 # CONFIG_CRYPTO_LIB_CURVE25519 is not set
index a7668acfadef360f1b1d6d7567c7a38f13bf9d63..dfba811f31f20e6e3e7c30ed2afc7291b92228cf 100644 (file)
@@ -4,7 +4,7 @@ from backports.
 
 --- a/lib/crypto/Kconfig
 +++ b/lib/crypto/Kconfig
-@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
+@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
        tristate
  
  config CRYPTO_LIB_ARC4
@@ -12,4 +12,4 @@ from backports.
 +      tristate "ARC4 cipher library"
  
  config CRYPTO_ARCH_HAVE_LIB_BLAKE2S
-       tristate
+       bool
index f46877f254dd262bc1f5e42aec3477504cea2c9d..f1f35c9923a669d4af54da8833d6a96f80620c05 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/lib/vsprintf.c
 +++ b/lib/vsprintf.c
-@@ -983,8 +983,10 @@ char *symbol_string(char *buf, char *end
+@@ -985,8 +985,10 @@ char *symbol_string(char *buf, char *end
                    struct printf_spec spec, const char *fmt)
  {
        unsigned long value;
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif
  
        if (fmt[1] == 'R')
-@@ -1001,8 +1003,14 @@ char *symbol_string(char *buf, char *end
+@@ -1003,8 +1005,14 @@ char *symbol_string(char *buf, char *end
  
        return string_nocheck(buf, end, sym, spec);
  #else
index cc5ee924669e16764dd6dde4db8e90f33bece5d7..845441b4257fb6cd578e4e21939a2b15fc198ba2 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -14814,6 +14814,13 @@ S:    Maintained
+@@ -14816,6 +14816,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*