tools: fix dependencies of cmake packages
authorFelix Fietkau <nbd@nbd.name>
Sat, 12 Jun 2021 10:40:02 +0000 (12:40 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 12 Jun 2021 10:40:27 +0000 (12:40 +0200)
Make cmake depend on ninja, so that other cmake based tools also depend on it

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/Makefile

index 47a82fd2378286de5db6ed0332b29a6572430f42..dccf298af6eef58e669f36c6724f4db4dd070117 100644 (file)
@@ -43,7 +43,7 @@ $(curdir)/b43-tools/compile := $(curdir)/bison/compile
 $(curdir)/bc/compile := $(curdir)/bison/compile $(curdir)/libtool/compile
 $(curdir)/bison/compile := $(curdir)/flex/compile
 $(curdir)/cbootimage/compile += $(curdir)/automake/compile
-$(curdir)/cmake/compile += $(curdir)/libressl/compile
+$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile
 $(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
 $(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
 $(curdir)/fakeroot/compile := $(curdir)/libtool/compile