layerscape: unbreak ehci-fsl interaction with mpc85xx
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 14 Apr 2019 20:34:52 +0000 (22:34 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 14 Apr 2019 22:20:56 +0000 (00:20 +0200)
Both targets have their own idea of how to use ehci-fsl.
This patch reverts part of commit
68b8d3b0796d ("kernel: usb: add FSL EHCI package") and moves
ehci-fsl back into kmod-usb2, while also making it hopefully
useable for the mpc85xx target.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/kernel/linux/modules/usb.mk
target/linux/mpc85xx/Makefile

index f11758c6623b84432db445d503bb9c247da9287d..e2fe06f977ef66cdd2ef826e6c75e25873117559 100644 (file)
@@ -385,7 +385,8 @@ define KernelPackage/usb2
        CONFIG_USB_EHCI_MXC=y \
        CONFIG_USB_OCTEON_EHCI=y \
        CONFIG_USB_EHCI_HCD_ORION=y \
-       CONFIG_USB_EHCI_HCD_AT91=y
+       CONFIG_USB_EHCI_HCD_AT91=y \
+       CONFIG_USB_EHCI_FSL
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
   ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
@@ -394,7 +395,13 @@ define KernelPackage/usb2
   ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
     FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
   endif
-  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko
+  endif
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel ehci-fsl fsl-mph-dr-of,1)
   $(call AddDepends/usb)
 endef
 
@@ -405,26 +412,6 @@ endef
 $(eval $(call KernelPackage,usb2))
 
 
-define KernelPackage/usb2-fsl
-  TITLE:=Support for Freescale USB2 controllers
-  DEPENDS:=+kmod-usb-ehci @TARGET_mpc85xx
-  KCONFIG:= \
-       CONFIG_USB_EHCI_HCD_PPC_OF=y \
-       CONFIG_USB_EHCI_FSL=y
-  FILES:= \
-       $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
-       $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
-  AUTOLOAD:=$(call AutoLoad,42,ehci-fsl fsl-mph-dr-of,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb2-fsl/description
- Kernel support for Freescale USB2 (EHCI) controllers
-endef
-
-$(eval $(call KernelPackage,usb2-fsl))
-
-
 define KernelPackage/usb2-pci
   TITLE:=Support for PCI USB2 controllers
   DEPENDS:=@PCI_SUPPORT +kmod-usb2
index 02fdc2f53da6030c983062cf5933311d4adc0cba..e08b00ab8e9baf31d440e82310b91d10824a5e80 100644 (file)
@@ -22,6 +22,6 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2
 
 $(eval $(call BuildTarget))