octeon: fix mtd partitions for erlite on cmdline
authorJiri Kastner <cz172638@gmail.com>
Wed, 18 Jan 2017 09:45:23 +0000 (10:45 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Feb 2017 16:39:09 +0000 (17:39 +0100)
erlite mtdparts exposes boot0, boot1 and eeprom regions
as read/write.
this patch adds readonly flags, so these regions can't be
modified. same as it is already for ER profile.

Signed-off-by: Jiri Kastner <cz172638@gmail.com>
target/linux/octeon/image/Makefile

index 62e55dcf5d71a4a6fe5754315a942d0d388a203e..299e9ba3965435acb8a00d7cefc02a5df79ccb80 100644 (file)
@@ -35,7 +35,7 @@ define Device/er
 endef
 TARGET_DEVICES += er
 
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
 define Device/erlite
   CMDLINE := $(ERLITE_CMDLINE) 
   DEVICE_TITLE := Ubiquiti EdgeRouter Lite