kernel: add fake users for udptunnel and iptunnel modules
authorDaniel Golle <daniel@makrotopia.org>
Mon, 22 Aug 2016 15:14:03 +0000 (17:14 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 22 Aug 2016 15:23:05 +0000 (17:23 +0200)
Without any in-tree users enabled the Kernel's build process doesn't
actually build those modules. Enable some potential in-tree users
during Kernel build, so out-of-tree modules can depend on them.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/netsupport.mk

index c68be90ad2437ff70588219970dda6ce535f54ab..e52dab6da1c19e383664d326ef3330cf6679907b 100644 (file)
@@ -148,7 +148,9 @@ $(eval $(call KernelPackage,8021q))
 define KernelPackage/udptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 UDP tunneling support
-  KCONFIG:=CONFIG_NET_UDP_TUNNEL
+  KCONFIG:= \
+       CONFIG_NET_UDP_TUNNEL \
+       CONFIG_VXLAN=m
   HIDDEN:=1
   FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
@@ -161,7 +163,9 @@ define KernelPackage/udptunnel6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv6 UDP tunneling support
   DEPENDS:=@IPV6
-  KCONFIG:=CONFIG_NET_UDP_TUNNEL
+  KCONFIG:= \
+       CONFIG_NET_UDP_TUNNEL \
+       CONFIG_VXLAN=m
   HIDDEN:=1
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
@@ -444,7 +448,8 @@ define KernelPackage/iptunnel4
   TITLE:=IPv4 tunneling
   HIDDEN:=1
   KCONFIG:= \
-       CONFIG_INET_TUNNEL
+       CONFIG_INET_TUNNEL \
+       CONFIG_NET_IPIP=m
   FILES:=$(LINUX_DIR)/net/ipv4/tunnel4.ko
   AUTOLOAD:=$(call AutoLoad,31,tunnel4)
 endef