gemini: Cook a WRGG firmware image
authorLinus Walleij <linus.walleij@linaro.org>
Wed, 13 Jun 2018 15:45:04 +0000 (17:45 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 04:35:09 +0000 (06:35 +0200)
This makes the Gemini build a WRGG-type firmware update
image for the DIR-685. This should hopefully install the
kernel from the web firmware upgrade API on the product
switching it permanently to use OpenWRT.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/gemini/image/Makefile

index 3e122fc457ae8915df1ba8e9be7200cea1062d30..b631452a0ffb63984fb86329f1f1bf27668c965f 100644 (file)
@@ -7,9 +7,17 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-# Just copy the zImage for D-Link DIR-685
+# Cook a "WRGG" image, this board is apparently one in the D-Link
+# WRGG family and uses the exact same firmware format as other
+# D-Link devices.
 define Build/dir685-images
-       cp $(IMAGE_KERNEL) $(BIN_DIR)/$(IMG_PREFIX)-dir685-zImage
+       mkwrggimg -i $(IMAGE_KERNEL) \
+       -o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+       -d /dev/mtdblock/1 \
+       -s wrgns01_dlwbr_dir685RBWW \
+       -v 'N/A' \
+       -m dir685 \
+       -B 96bb
 endef
 
 # Build D-Link DNS-313 images using the special header tool.