uboot-lantiq: reuse/copy VR9 GPHY firmware blobs from target/linux/lantiq
authorJohn Crispin <john@openwrt.org>
Sat, 12 Apr 2014 21:21:35 +0000 (21:21 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 12 Apr 2014 21:21:35 +0000 (21:21 +0000)
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
SVN-Revision: 40487

package/boot/uboot-lantiq/Makefile

index c0a8b6e386bd96db9365dc3d98a68480a93eb686..078c79c0549ac90be84e0f78855526029603c728 100644 (file)
@@ -21,6 +21,8 @@ PKG_TARGETS:=bin
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
+FIRMWARE_LANTIQ_SOURCE:=$(TOPDIR)/target/linux/lantiq/files/firmware/lantiq
+
 include $(INCLUDE_DIR)/package.mk
 
 define uboot/Default
@@ -202,6 +204,19 @@ define BuildUBootPackage
        $(call Package/uboot/template,$(1),$(TITLE))
 endef
 
+define CopyVR9Firmware
+       $(CP) $(FIRMWARE_LANTIQ_SOURCE)/vr9_phy$(1)_a$(2)x.bin \
+               $(PKG_BUILD_DIR)/arch/mips/cpu/mips32/vrx200/fw_phy$(1)_a$(2)x.blob
+endef
+
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(call CopyVR9Firmware,11g,1)
+       $(call CopyVR9Firmware,11g,2)
+       $(call CopyVR9Firmware,22f,1)
+       $(call CopyVR9Firmware,22f,2)
+endef
+
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) $(BUILD_VARIANT)_config
 endef