use file descriptors 8 and 9 for build system internal log messages, as apparently...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jun 2008 21:57:57 +0000 (21:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 16 Jun 2008 21:57:57 +0000 (21:57 +0000)
SVN-Revision: 11515

include/verbose.mk

index b414d244098cbe68a0d5653b14a686982cac0fba..8b82cde7beb153ea2bb7bae5bb088da32d21e43e 100644 (file)
@@ -25,7 +25,7 @@ endif
 
 ifneq ($(KBUILD_VERBOSE),99)
   define MESSAGE
-       printf "$(_Y)%s$(_N)\n" "$(1)" >&254
+       printf "$(_Y)%s$(_N)\n" "$(1)" >&8
   endef
 
   ifeq ($(QUIET),1)
@@ -45,7 +45,7 @@ ifneq ($(KBUILD_VERBOSE),99)
       SILENT:=
     endif
     export QUIET:=1
-    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 254>&1 255>&2; cmd
+    SUBMAKE=cmd() { $(SILENT) $(MAKE) -s $$* || { echo "make $$*: build failed. Please re-run make with V=99 to see what's going on"; false; } } 8>&1 9>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)