target/mpc85xx: check if 'generic' subtarget for image file cuImage.tl-wdr4900-v1
authorJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:25:28 +0000 (10:25 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:25:28 +0000 (10:25 +0000)
Only add 'cuImage.tl-wdr4900-v1' to KERNEL_IMAGES if
the selected subtarget is 'generic'.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 47109

target/linux/mpc85xx/Makefile

index e43327acd82fcf5daf8cc735a4b64a46ed8da515..5f3ad6c3d4968774229e51cdaab06805347189e5 100644 (file)
@@ -16,10 +16,13 @@ SUBTARGETS=generic p1020
 
 KERNEL_PATCHVER:=3.18
 
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
-
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio kmod-booke-wdt \