Fix ne2k-pci compilation (#957)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 18 Nov 2006 00:02:14 +0000 (00:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 18 Nov 2006 00:02:14 +0000 (00:02 +0000)
SVN-Revision: 5558

package/kernel/modules/network.mk

index 000d5206c325b5285e5676a609540643e5469a41..c377c309e1211494e540f20ad72181b53fe3b8e4 100644 (file)
@@ -310,11 +310,12 @@ define KernelPackage/ne2k-pci
   TITLE:=ne2k-pci Ethernet Adapter kernel support
   DESCRIPTION:=\
        ne2k-pci Ethernet Adapter kernel support.
-  FILES:=$(MODULES_DIR)/kernel/drivers/net/ne2k-pci.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(MODULES_DIR)/kernel/drivers/net/ne2k-pci.$(LINUX_KMOD_SUFFIX) \
+       $(MODULES_DIR)/kernel/drivers/net/8390.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=$(CONFIG_NE2K-PCI)
   DEPENDS:=@LINUX_2_6_X86
   SUBMENU:=$(NDMENU)
-  AUTOLOAD:=$(call AutoLoad,50,ne2k-pci)
+  AUTOLOAD:=$(call AutoLoad,50,8390 ne2k-pci)
 endef
 $(eval $(call KernelPackage,ne2k-pci))