fix KBUILD_VERBOSE if V is unset
authorFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jul 2006 21:28:59 +0000 (21:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 18 Jul 2006 21:28:59 +0000 (21:28 +0000)
SVN-Revision: 4160

openwrt/include/verbose.mk

index 58a20a217841e8d5ceb8dc10741a8a10717b222c..16a75c08c9744ff741d46f397576d697c4a9d11f 100644 (file)
@@ -9,7 +9,10 @@
 NO_TRACE_MAKE:=$(MAKE) V=99
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=$(V)
+  KBUILD_VERBOSE=0
+  ifdef V
+    KBUILD_VERBOSE=$(V)
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)