wolfssl: set nonshared flag global
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Wed, 8 Jun 2022 22:40:47 +0000 (00:40 +0200)
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Wed, 8 Jun 2022 22:47:13 +0000 (00:47 +0200)
libwolfssl-benchmark should NOT be compiled as nonshared but
currently there is a bug where, on buildbot stage2, the package
is recompiled to build libwolfssl-benchmark and the dependency
change to the new libwolfssl version.
Each dependant package will now depend on the new wolfssl package
instead of the one previously on stage1 that has a different package
HASH.

Set the nonshared PKGFLAGS global while this gets investigated
and eventually fixed.

Fixes: 0a2edc2714dc ("wolfssl: enable CPU crypto instructions")
Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
package/libs/wolfssl/Makefile

index 3edd526364041d646a41c4990c4a765d31882e94..7176995ec201e6504e13abb625cb71fa0a8c8102 100644 (file)
@@ -48,6 +48,15 @@ PKG_CONFIG_DEPENDS+=\
        CONFIG_WOLFSSL_HAS_DEVCRYPTO_CBC \
        CONFIG_WOLFSSL_HAS_DEVCRYPTO_FULL
 
+#
+# libwolfssl-benchmark should NOT be compiled as nonshared but
+# currently there is a bug where on buildbot stage2 the package
+# is recompiled to build libwolfssl-benchmark and the dependency
+# change to the new libwolfssl version. While this gets
+# investigated, set the nonshared flag global
+#
+PKGFLAGS:=nonshared
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libwolfssl/Default
@@ -60,7 +69,6 @@ endef
 define Package/libwolfssl
 $(call Package/libwolfssl/Default)
   TITLE:=wolfSSL library
-  PKGFLAGS:=nonshared
   MENU:=1
   PROVIDES:=libcyassl
   DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user