ipq806x: Enable ubi image for ipq40xx AP-DK04.1-C1 board
authorRam Chandra Jangir <rjangir@codeaurora.org>
Wed, 31 May 2017 15:20:29 +0000 (20:50 +0530)
committerJohn Crispin <john@phrozen.org>
Wed, 7 Jun 2017 04:33:33 +0000 (06:33 +0200)
This change add IPQ40xx AP-DK04.1-C1 board image support,
enables ubi image for IPQ40xx AP-DK04.1-C1 board and also
add sysupgrage support for AP-DK04.1-C1 and generates a
sysupgrade.tar image.

Testing:
 *Tested on IPQ40xx AP-DK04.1-C1:
   a. NAND boot
   b. ubi sysupgrade

Signed-off-by: Ram Chandra Jangir <rjangir@codeaurora.org>
target/linux/ipq806x/base-files/lib/upgrade/platform.sh
target/linux/ipq806x/image/Makefile

index 89702850fca9a6a2234beec71019a53b5f2aeeac..fd08db3b08486aeb1e2d0bb651c7371db2f2131a 100644 (file)
@@ -12,6 +12,7 @@ platform_pre_upgrade() {
 
        case "$board" in
        ap148 |\
+       ap-dk04.1-c1 |\
        d7800 |\
        nbg6817 |\
        r7500 |\
index de6ddb6a93f3270f2eea1d80566bbfe535b8e6ad..4ed05eb94009edd90dadb05c6118252250ad6a5b 100644 (file)
@@ -250,7 +250,20 @@ define Device/VR2600v
        IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
 endef
 
+define Device/AP-DK04.1-C1
+       $(call Device/FitImage)
+       $(call Device/UbiFit)
+       DEVICE_DTS := qcom-ipq4019-ap.dk04.1-c1
+       KERNEL_LOADADDR := 0x80208000
+       KERNEL_INSTALL := 1
+       KERNEL_SIZE := 4048k
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       BOARD_NAME := ap-dk04.1-c1
+       DEVICE_TITLE := QCA AP-DK04.1-C1
+endef
+
 TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 FRITZ4040 R7500 \
-                 R7500v2 R7800 NBG6817 VR2600v
+                 R7500v2 R7800 NBG6817 VR2600v AP-DK04.1-C1
 
 $(eval $(call BuildImage))