toolchain/binutils: add support for version 2.30
authorFelix Fietkau <nbd@nbd.name>
Thu, 8 Mar 2018 10:21:58 +0000 (11:21 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 12 Mar 2018 19:01:07 +0000 (20:01 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/binutils/Config.in
toolchain/binutils/Config.version
toolchain/binutils/Makefile
toolchain/binutils/patches/2.30/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/patches/2.30/300-012_check_ldrunpath_length.patch [new file with mode: 0644]
toolchain/binutils/patches/2.30/400-mips_no_dynamic_linking_sym.patch [new file with mode: 0644]
toolchain/binutils/patches/2.30/500-Change-default-emulation-for-mips64-linux.patch [new file with mode: 0644]

index 56bcd162a2bdca950ba8a5d35b25103371f2d0f2..51cd3d8df0154bd70028b006d32b0c45e4fd0edf 100644 (file)
@@ -27,6 +27,11 @@ choice
                bool "Binutils 2.29.1"
                select BINUTILS_VERSION_2_29_1
 
+       config BINUTILS_USE_VERSION_2_30
+               depends on !arc
+               bool "Binutils 2.30"
+               select BINUTILS_VERSION_2_30
+
 endchoice
 
 config EXTRA_BINUTILS_CONFIG_OPTIONS
index 159a25f10f2a1d7f465d904b57cd807b93b4796f..63a376f83d93545f105ad51bcb31274291237ea6 100644 (file)
@@ -12,9 +12,13 @@ config BINUTILS_VERSION_2_29_ARC
 config BINUTILS_VERSION_2_29_1
        bool
 
+config BINUTILS_VERSION_2_30
+       bool
+
 config BINUTILS_VERSION
        string
        default "2.27"                 if BINUTILS_VERSION_2_27
        default "2.28"                 if BINUTILS_VERSION_2_28
        default "2.29.1"               if BINUTILS_VERSION_2_29_1
+       default "2.30"                 if BINUTILS_VERSION_2_30
        default "arc-2017.09"          if BINUTILS_VERSION_2_29_ARC
index c46d29933db134b5665949e3b7d7df681f0ada2e..2a1b1015c9dcdf65cd227756fc02119f44adfd25 100644 (file)
@@ -25,6 +25,10 @@ ifeq ($(PKG_VERSION),2.29.1)
   PKG_HASH:=1509dff41369fb70aed23682351b663b56db894034773e6dbf7d5d6071fc55cc
 endif
 
+ifeq ($(PKG_VERSION),2.30)
+  PKG_HASH:=efeade848067e9a03f1918b1da0d37aaffa0b0127a06b5e9236229851d9d0c09
+endif
+
 ifneq ($(CONFIG_BINUTILS_VERSION_2_29_ARC),)
   PKG_REV:=arc-2017.09-release
   PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/$(PKG_REV)/
diff --git a/toolchain/binutils/patches/2.30/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.30/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..4365197
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/ld/Makefile.am
++++ b/ld/Makefile.am
+@@ -57,7 +57,7 @@ endif
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- a/ld/Makefile.in
++++ b/ld/Makefile.in
+@@ -446,7 +446,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.30/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.30/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..6f51a72
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/ld/emultempl/elf32.em
++++ b/ld/emultempl/elf32.em
+@@ -1470,6 +1470,8 @@ fragment <<EOF
+             && command_line.rpath == NULL)
+           {
+             path = (const char *) getenv ("LD_RUN_PATH");
++            if ((path) && (strlen (path) == 0))
++              path = NULL;
+             if (path
+                 && gld${EMULATION_NAME}_search_needed (path, &n, force))
+               break;
+@@ -1750,6 +1752,8 @@ gld${EMULATION_NAME}_before_allocation (
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   for (abfd = link_info.input_bfds; abfd; abfd = abfd->link.next)
+     if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
diff --git a/toolchain/binutils/patches/2.30/400-mips_no_dynamic_linking_sym.patch b/toolchain/binutils/patches/2.30/400-mips_no_dynamic_linking_sym.patch
new file mode 100644 (file)
index 0000000..5f7192a
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/bfd/elfxx-mips.c
++++ b/bfd/elfxx-mips.c
+@@ -7877,6 +7877,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+       name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
+       bh = NULL;
++      if (0) {
+       if (!(_bfd_generic_link_add_one_symbol
+           (info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
+            NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
+@@ -7889,6 +7890,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+       if (! bfd_elf_link_record_dynamic_symbol (info, h))
+       return FALSE;
++      }
+       if (! mips_elf_hash_table (info)->use_rld_obj_head)
+       {
diff --git a/toolchain/binutils/patches/2.30/500-Change-default-emulation-for-mips64-linux.patch b/toolchain/binutils/patches/2.30/500-Change-default-emulation-for-mips64-linux.patch
new file mode 100644 (file)
index 0000000..daf118f
--- /dev/null
@@ -0,0 +1,37 @@
+--- a/bfd/config.bfd
++++ b/bfd/config.bfd
+@@ -1189,12 +1189,12 @@ case "${targ}" in
+     targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
+     ;;
+   mips64*el-*-linux*)
+-    targ_defvec=mips_elf32_ntrad_le_vec
+-    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
++    targ_defvec=mips_elf64_trad_le_vec
++    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
+     ;;
+   mips64*-*-linux*)
+-    targ_defvec=mips_elf32_ntrad_be_vec
+-    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
++    targ_defvec=mips_elf64_trad_be_vec
++    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
+     ;;
+   mips*el-*-linux*)
+     targ_defvec=mips_elf32_trad_le_vec
+--- a/ld/configure.tgt
++++ b/ld/configure.tgt
+@@ -535,11 +535,11 @@ mips*el-*-vxworks*)      targ_emul=elf32elmip
+ mips*-*-vxworks*)     targ_emul=elf32ebmipvxworks
+                       targ_extra_emuls="elf32elmipvxworks" ;;
+ mips*-*-windiss)      targ_emul=elf32mipswindiss ;;
+-mips64*el-*-linux-*)  targ_emul=elf32ltsmipn32
+-                      targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
++mips64*el-*-linux-*)  targ_emul=elf64ltsmip
++                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
+                       targ_extra_libpath=$targ_extra_emuls ;;
+-mips64*-*-linux-*)    targ_emul=elf32btsmipn32
+-                      targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
++mips64*-*-linux-*)    targ_emul=elf64btsmip
++                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
+                       targ_extra_libpath=$targ_extra_emuls ;;
+ mips*el-*-linux-*)    targ_emul=elf32ltsmip
+                       targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"