set version string of eglibc version 2.14 to 2.14.1
authorMirko Vogt <mirko@openwrt.org>
Sat, 28 Apr 2012 20:18:06 +0000 (20:18 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 28 Apr 2012 20:18:06 +0000 (20:18 +0000)
eglibc version number depends on the branch and on the maintenance release
(i.e. the SVN revision). Changing the revision may change the maintenance
version. This patch correlate the SVN revision to the correct version
number - without this change  eglibc 2.14 provoke build errors when
building the base-files package (example, for 2.14):

$ make package/base-files/compile V=1
   make[1] package/base-files/compile
   make[2] -C package/opkg host-compile
   make[2] -C package/base-files-network compile
   make[2] -C package/base-files compile
cp: cannot stat `/home/me/openwrt/trunk/staging_dir/toolchain-arm_v7-a_gcc-4.6-linaro_eglibc-trunk_eabi/lib/ld-2.14.so': No such file or directory

Signed-off-by: Emmanuel Deloget <logout@free.fr>
SVN-Revision: 31501

toolchain/eglibc/Config.version

index 7ca4e17..b081cec 100644 (file)
@@ -2,5 +2,5 @@ config EGLIBC_VERSION
        string
        depends on USE_EGLIBC
        default "2.13"   if EGLIBC_VERSION_2_13
-       default "2.14"   if EGLIBC_VERSION_2_14
+       default "2.14.1"   if EGLIBC_VERSION_2_14
        default "trunk"