at91: split up remaining DEVICE_TITLE definitions
authorMoritz Warning <moritzwarning@web.de>
Mon, 9 Sep 2019 22:00:40 +0000 (00:00 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Oct 2019 11:16:57 +0000 (13:16 +0200)
DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT

Signed-off-by: Moritz Warning <moritzwarning@web.de>
target/linux/at91/image/sama5.mk

index 1e4366cefa557c002cbc4672cde6ba99cfff3108..031e62587e5a0cde41e9fbb46060a30a1ce0bae4 100644 (file)
@@ -56,7 +56,8 @@ endef
 
 define Device/at91-sama5d2_xplained
   $(Device/evaluation-dtb)
-  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D2 Xplained
   KERNEL_SIZE := 6144k
   $(Device/evaluation-sdimage)
 endef
@@ -64,7 +65,8 @@ TARGET_DEVICES += at91-sama5d2_xplained
 
 define Device/at91-sama5d27_som1_ek
   $(Device/evaluation-dtb)
-  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D27 SOM1 Ek
   KERNEL_SIZE := 6144k
   $(Device/evaluation-sdimage)
 endef
@@ -72,7 +74,8 @@ TARGET_DEVICES += at91-sama5d27_som1_ek
 
 define Device/at91-sama5d2_ptc_ek
   $(Device/evaluation-dtb)
-  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D2 PTC Ek
   KERNEL_SIZE := 6144k
   $(Device/evaluation-sdimage)
 endef
@@ -81,7 +84,8 @@ TARGET_DEVICES += at91-sama5d2_ptc_ek
 
 define Device/at91-sama5d3_xplained
   $(Device/evaluation-dtb)
-  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D3 Xplained
   KERNEL_SIZE := 6144k
   $(Device/evaluation-sdimage)
 endef
@@ -91,7 +95,8 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
  ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
   define Device/wb50n
     $(Device/evaluation-fit)
-    DEVICE_TITLE := Laird WB50N
+    DEVICE_VENDOR := Laird
+    DEVICE_MODEL := WB50N
     DEVICE_PACKAGES := \
          kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
          kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
@@ -108,7 +113,8 @@ endif
 
 define Device/at91-sama5d4_xplained
   $(Device/evaluation-dtb)
-  DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+  DEVICE_VENDOR := Microchip
+  DEVICE_MODEL := SAMA5D4 Xplained
   KERNEL_SIZE := 6144k
   BLOCKSIZE := 256k
   PAGESIZE := 4096