openssl: add option to disable PSK support
authorDirk Feytons <dirk.feytons@gmail.com>
Fri, 20 May 2016 15:23:28 +0000 (17:23 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 23 Jul 2016 09:59:31 +0000 (11:59 +0200)
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
package/libs/openssl/Config.in
package/libs/openssl/Makefile

index 492b042864c4ad0bd3ca7e022331e95b077376dc..7224b65a4b1387149a5755c24f18ebf5380697c2 100644 (file)
@@ -30,6 +30,11 @@ config OPENSSL_WITH_NPN
        default n
        prompt "Enable NPN support"
 
+config OPENSSL_WITH_PSK
+       bool
+       default y
+       prompt "Enable PSK support"
+
 config OPENSSL_ENGINE_DIGEST
        bool
        depends on OPENSSL_ENGINE_CRYPTO
index 33b47aa9301aa6dfa21387c39f19e7dbee0ebd81..7cd306ba6346390634c6dccff50905a0c7e2a88f 100644 (file)
@@ -35,7 +35,8 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_HARDWARE_SUPPORT \
        CONFIG_OPENSSL_WITH_DEPRECATED \
        CONFIG_OPENSSL_WITH_COMPRESSION \
-       CONFIG_OPENSSL_WITH_NPN
+       CONFIG_OPENSSL_WITH_NPN \
+       CONFIG_OPENSSL_WITH_PSK
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -136,6 +137,10 @@ ifndef CONFIG_OPENSSL_WITH_NPN
   OPENSSL_OPTIONS += no-nextprotoneg
 endif
 
+ifndef CONFIG_OPENSSL_WITH_PSK
+  OPENSSL_OPTIONS += no-psk
+endif
+
 ifeq ($(CONFIG_x86_64),y)
   OPENSSL_TARGET:=linux-x86_64-openwrt
   OPENSSL_MAKEFLAGS += LIBDIR=lib