add conffiles, use proper optimization flags when building.
authorNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:27:23 +0000 (18:27 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:27:23 +0000 (18:27 +0000)
SVN-Revision: 3997

openwrt/package/dnsmasq/Makefile

index d3ce64736b7aa371eb16861cb7450cee4d3fd12c..6efaf370a1e3a44e54155eebffa4b6a1fa0d50cf 100644 (file)
@@ -24,12 +24,24 @@ coupled DNS and DHCP service to a LAN.
 URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
+define Package/dnsmasq/conffiles
+/etc/dnsmasq.conf
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               all
+endef
+
 define Package/dnsmasq/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 -d $(1)/etc/init.d/
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       install -m0755 -d $(1)/etc
        install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       install -m0755 -d $(1)/etc/init.d
        install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/S50dnsmasq
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,dnsmasq))