ar71xx: Fix network setup for TP-Link Archer C25 v1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 9 May 2019 15:02:36 +0000 (17:02 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 15 May 2019 11:34:24 +0000 (13:34 +0200)
Network for the Archer C25 v1 is set up without switch for no
obvious reason. The LED setup is even done switch-based.

This patch changes network setup so a switch is created.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ar71xx/base-files/etc/board.d/02_network

index b06ec4b..79f9e55 100755 (executable)
@@ -160,7 +160,6 @@ ar71xx_setup_interfaces()
        a60|\
        alfa-ap96|\
        alfa-nx|\
-       archer-c25-v1|\
        dr344|\
        gl-ar150|\
        gl-ar300m|\
@@ -182,15 +181,6 @@ ar71xx_setup_interfaces()
        wrtnode2q)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
-       rb-750-r2|\
-       rb-750p-pbr2|\
-       rb-750up-r2|\
-       rb-951ui-2nd|\
-       rb-952ui-5ac2nd)
-               ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
-               ucidef_add_switch "switch0" \
-                       "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
-               ;;
        all0258n|\
        all0315n|\
        dlan-hotspot|\
@@ -248,6 +238,16 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
+       archer-c25-v1|\
+       rb-750-r2|\
+       rb-750p-pbr2|\
+       rb-750up-r2|\
+       rb-951ui-2nd|\
+       rb-952ui-5ac2nd)
+               ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
+               ucidef_add_switch "switch0" \
+                       "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
+               ;;
        archer-c58-v1|\
        archer-c59-v1|\
        archer-c59-v2|\