sdk: rename file to mention target/subtarget and move host system to suffix
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Feb 2015 21:01:43 +0000 (21:01 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Feb 2015 21:01:43 +0000 (21:01 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44312

target/sdk/Makefile

index 9e8749b080f9dca904c0c32e5cfd1cff4810cc7e..8ae63c4314fa52960909160dd31ec94f85121a1c 100644 (file)
@@ -12,10 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 
 override MAKEFLAGS=
 
-PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-
-SDK_NAME:=OpenWrt-SDK-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)-for-$(PKG_OS)-$(PKG_CPU)-gcc-$(GCCV)_$(LIBC)-$(LIBCV)
+SDK_NAME:=OpenWrt-SDK-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
 SDK_BUILD_DIR:=$(BUILD_DIR)/$(SDK_NAME)
 
 STAGING_SUBDIR_HOST := staging_dir/host