mvebu: wrt3200acm enable SDIO interface
authorHenryk Heisig <hyniu@o2.pl>
Tue, 28 Feb 2017 05:30:25 +0000 (06:30 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sat, 11 Mar 2017 19:34:33 +0000 (20:34 +0100)
add mwifiex-sdio package to wrt3200acm

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
target/linux/mvebu/files/arch/arm/boot/dts/armada-385-linksys-rango.dts
target/linux/mvebu/image/Makefile

index 804ba0d6aa73399a91c10624037d591a5ca7519d..ea1af6f9dac3850275664c53cfdbf947fad0ca82 100644 (file)
                                status = "okay";
                        };
 
+                       sdhci@d8000 {
+                               pinctrl-names = "default";
+                               pinctrl-0 = <&sdhci_pins>;
+                               no-1-8-v;
+                               broken-cd;
+                               wp-inverted;
+                               bus-width = <8>;
+                               status = "okay";
+                       };
+
                        /* USB part of the eSATA/USB 2.0 port */
                        usb@58000 {
                                status = "okay";
index bef699c2e7708bfe20999683d6212bab013035aa..05c46481b1b9b1b21a2770686b206e18a861e236 100644 (file)
@@ -114,6 +114,7 @@ define Device/linksys-wrt3200acm
   $(call Device/linksys,WRT3200ACM (Rango))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-rango
+  DEVICE_PACKAGES += kmod-mwifiex-sdio
 endef
 TARGET_DEVICES += linksys-wrt3200acm