kernel: bump 4.14 to 4.14.88
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 13 Dec 2018 10:53:31 +0000 (11:53 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 14 Dec 2018 12:01:49 +0000 (13:01 +0100)
Refreshed all patches.

Altered patches:
- 180-usb-xhci-add-support-for-performing-fake-doorbell.patch

Fixes CVE:
- CVE-2018-14625

Compile-tested on: ar71xx, cns3xxx, imx6
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/801-usb-xhci-add-firmware-loader-for-uPD720201-and-uPD72.patch
target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm53xx/patches-4.14/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/pending-4.14/120-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
target/linux/mediatek/patches-4.14/0191-usb-xhci-allow-imod-interval-to-be-configurable.patch

index 4218e3df36a4d3c0b7dacb73ec9d3bdc1512c944..7433b31078b5e758fd0b284bf5289fa4c89b8fc9 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .129
 LINUX_VERSION-4.9 = .145
-LINUX_VERSION-4.14 = .87
+LINUX_VERSION-4.14 = .88
 
 LINUX_KERNEL_HASH-3.18.129 = 8d420b58593a74109175be781da2320a341baec9aaa186da31ad508d3f377e72
 LINUX_KERNEL_HASH-4.9.145 = 6901ca37e8c305a2f26c598952338b4dc2481ca5a9d0bf71e2b71730a5b5bc5e
-LINUX_KERNEL_HASH-4.14.87 = 36744d7d657dab23e455a8096e4ad2dc6a25f25fdce062d8a8bdf4499112e125
+LINUX_KERNEL_HASH-4.14.88 = b0f0b8c76708eab6caf3009702e531d40a243b152922ee1f9a441316f226f52d
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index a06910b816872e79257e233a6bc6e050d7b9f5fe..41f9c8ac7db22af61fda06ae273159cd75d96232 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  
  #include "xhci.h"
  #include "xhci-trace.h"
-@@ -262,6 +264,458 @@ static void xhci_pme_acpi_rtd3_enable(st
+@@ -266,6 +268,458 @@ static void xhci_pme_acpi_rtd3_enable(st
  static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { }
  #endif /* CONFIG_ACPI */
  
@@ -503,7 +503,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
  /* called during probe() after chip reset completes */
  static int xhci_pci_setup(struct usb_hcd *hcd)
  {
-@@ -297,6 +751,22 @@ static int xhci_pci_probe(struct pci_dev
+@@ -301,6 +755,22 @@ static int xhci_pci_probe(struct pci_dev
        struct hc_driver *driver;
        struct usb_hcd *hcd;
  
@@ -526,7 +526,7 @@ Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
        driver = (struct hc_driver *)id->driver_data;
  
        /* For some HW implementation, a XHCI reset is just not enough... */
-@@ -361,6 +831,16 @@ static void xhci_pci_remove(struct pci_d
+@@ -365,6 +835,16 @@ static void xhci_pci_remove(struct pci_d
  {
        struct xhci_hcd *xhci;
  
index 60e539680478688c20b47ca0d4b609164cb508c6..71b90f2db2122bae5077fd383ed9ff9cc73986ab 100644 (file)
@@ -13,7 +13,7 @@ produce a noisy warning.
 
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -215,7 +215,7 @@ static void xhci_pci_quirks(struct devic
+@@ -219,7 +219,7 @@ static void xhci_pci_quirks(struct devic
                xhci->quirks |= XHCI_TRUST_TX_LENGTH;
        if (pdev->vendor == PCI_VENDOR_ID_RENESAS &&
                        pdev->device == 0x0015)
@@ -44,7 +44,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1857,6 +1857,7 @@ struct xhci_hcd {
+@@ -1858,6 +1858,7 @@ struct xhci_hcd {
        /* support xHCI 0.96 spec USB2 software LPM */
        unsigned                sw_lpm_support:1;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index f7dd241e2f0b4865900a71d41ed7e25d0e2147da..010842746459f8130f87592e7940a7a12e7a350e 100644 (file)
@@ -127,11 +127,11 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1839,6 +1839,7 @@ struct xhci_hcd {
- #define XHCI_SUSPEND_DELAY    BIT_ULL(30)
+@@ -1840,6 +1840,7 @@ struct xhci_hcd {
  #define XHCI_INTEL_USB_ROLE_SW        BIT_ULL(31)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
-+#define XHCI_FAKE_DOORBELL    BIT_ULL(35)
+ #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
++#define XHCI_FAKE_DOORBELL    BIT_ULL(36)
  
        unsigned int            num_active_eps;
        unsigned int            limit_active_eps;
index 53b1a9a13c42a1d4804e56ae9e831ac27c1ff4b2..88870bc99e80ccd43d422b94232c7fd26a1c98d4 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
 
 --- a/mm/page_alloc.c
 +++ b/mm/page_alloc.c
-@@ -6151,7 +6151,7 @@ static void __ref alloc_node_mem_map(str
+@@ -6141,7 +6141,7 @@ static void __ref alloc_node_mem_map(str
                mem_map = NODE_DATA(0)->node_mem_map;
  #if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
                if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
index d28993ae38ce11a453d010ec57381f14f4130951..2a6f5f25d4046fbcd74650c9f77191927adb85e5 100644 (file)
@@ -86,7 +86,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        if (!xhci->shared_hcd) {
 --- a/drivers/usb/host/xhci-pci.c
 +++ b/drivers/usb/host/xhci-pci.c
-@@ -273,6 +273,9 @@ static int xhci_pci_setup(struct usb_hcd
+@@ -277,6 +277,9 @@ static int xhci_pci_setup(struct usb_hcd
        if (!xhci->sbrn)
                pci_read_config_byte(pdev, XHCI_SBRN_OFFSET, &xhci->sbrn);