standardize Makefile
authorNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 19:30:35 +0000 (19:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 23 Sep 2006 19:30:35 +0000 (19:30 +0000)
SVN-Revision: 4843

openwrt/package/linux-atm/Makefile

index 55b044862e7896104ca1511c75c08664ff03c10c..291fe3573c86638327f5c49c5999d7271dd50128 100644 (file)
@@ -11,30 +11,38 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=linux-atm
 PKG_VERSION:=2.4.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
 
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/linux-atm/
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/linux-atm/
+PKG_MD5SUM:=84fef49cc39ff2605204246666f65864
 PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/linux-atm/Default
+  URL:=http://linux-atm.sourceforge.net/
+endef
+
 define Package/linux-atm
-SECTION:=libs
-CATEGORY:=Libraries
-TITLE:=Linux ATM Library
-DESCRIPTION:=Library for accessing the Linux ATM subsystem
+  $(call Package/linux-atm/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Linux ATM Library
+  DESCRIPTION:=\
+       This package contains a library for accessing the Linux ATM subsystem.
 endef
 
 define Package/br2684ctl
-SECTION:=net
-CATEGORY:=Network
-TITLE:=RFC2684 bridging
-DEPENDS:=+linux-atm
-DESCRIPTION:=ATM RFC2684 bridging utility
+  $(call Package/linux-atm/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+linux-atm
+  TITLE:=RFC2684 bridging utility
+  DESCRIPTION:=\
+       This package contains an ATM RFC2684 bridging utility.
 endef
 
 define Build/Configure
@@ -44,19 +52,10 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
-endef
-
-define Package/linux-atm/install
-       install -d -m0755 $(1)/usr/lib
-       cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
-endef
-
-define Package/br2684ctl/install
-       install -d -m0755 $(1)/etc/hotplug.d/net
-       install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
+       $(call Build/Compile/Default, \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
 endef
 
 define Build/InstallDev
@@ -73,5 +72,17 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libatm.{a,so*}
 endef
 
+define Package/linux-atm/install
+       install -d -m0755 $(1)/usr/lib
+       cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
+endef
+
+define Package/br2684ctl/install
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
+       install -d -m0755 $(1)/etc/hotplug.d/net
+       install -m0644 ./files/br2684.hotplug $(1)/etc/hotplug.d/net/30-br2684
+endef
+
 $(eval $(call BuildPackage,linux-atm))
 $(eval $(call BuildPackage,br2684ctl))