revert find | xargs => find | exec changes - this is completely unnecessary and intro...
[openwrt/staging/florian.git] / include / image.mk
index eb59ea651cd84e3fdc7f31f42a84f4375dcfe153..0e6a7cdbeab280b9615b210d0c4313f042e802ed 100644 (file)
@@ -79,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' -exec chmod 0644 {} \;
-       find $(BUILD_DIR)/root -type f -perm +0100 -exec chmod 0755 {} \;
-       find $(BUILD_DIR)/root -type d -exec chmod 0755 {} \;
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+       find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef