revert find | xargs => find | exec changes - this is completely unnecessary and intro...
[openwrt/staging/florian.git] / include / image.mk
index ec0512f904ffeb1ff1f003c9ab4636f1947c03c5..0e6a7cdbeab280b9615b210d0c4313f042e802ed 100644 (file)
@@ -17,6 +17,19 @@ JFFS2OPTS     :=  --pad --big-endian --squash
 SQUASHFS_OPTS :=  -be
 endif
 
+define add_jffs2_mark
+       echo -ne '\xde\xad\xc0\xde' >> $(1)
+endef
+
+# pad to 64k and add jffs2 end-of-filesystem mark
+# do this twice to make sure that this works with 128k blocksize as well
+define prepare_generic_squashfs
+       dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
+       dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       $(call add_jffs2_mark,$(1))
+endef
+
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
   ifeq ($(CONFIG_TARGET_ROOTFS_JFFS2),y)
     define Image/mkfs/jffs2
@@ -25,9 +38,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
 
+               
                # add End-of-Filesystem markers
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
-               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
+               $(call add_jffs2_mark,$(KDIR)/root.jffs2-64k)
+               $(call add_jffs2_mark,$(KDIR)/root.jffs2-128k)
        
                $(call Image/Build,jffs2-64k)
                $(call Image/Build,jffs2-128k)
@@ -47,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+  endef
 endif
 
 
@@ -63,9 +79,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
-       find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
-       find $(BUILD_DIR)/root -type d | xargs chmod 0755
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
+       find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
+       find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp
        chmod 0777 $(BUILD_DIR)/root/tmp
 endef