Update default configuration to use profiles
[openwrt/staging/florian.git] / include / target.mk
index ace3db0ffde3e9bde5ce7504320ee1f78ac4aa05..2f62c2a8cd72faa2a1b5bf045e8c9d994c44a239 100644 (file)
@@ -15,6 +15,7 @@ DEVICE_TYPE?=router
 DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
+DEFAULT_PACKAGES.bootloader:=
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
@@ -150,6 +151,13 @@ ifeq ($(DUMP),1)
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
   endif
+  DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -funit-at-a-time
+  DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
+  DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
+  DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
+  DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time
+  DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
+  DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -funit-at-a-time)
 endif
 
 define BuildTargets/DumpCurrent
@@ -163,6 +171,7 @@ define BuildTargets/DumpCurrent
         echo 'Target-Arch: $(ARCH)'; \
         echo 'Target-Features: $(FEATURES)'; \
         echo 'Target-Depends: $(DEPENDS)'; \
+        echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \