credit where credit is due
[openwrt/staging/florian.git] / openwrt / include / verbose.mk
index 1ef403ccfb95a1bce23da75a178621bdf1722874..98dfd5632b6292ded3459283c7a344f0fa149e6a 100644 (file)
@@ -1,18 +1,18 @@
-# OpenWrt.org 2006
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id:$
 
 ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=0
-  else
-    KBUILD_VERBOSE=99
-  endif
+  KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
     KBUILD_VERBOSE=$(V)
   endif
 endif
 
-
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
@@ -23,6 +23,7 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
+    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif