use hotplug2 for serializing hotplug events on 2.6
[openwrt/staging/florian.git] / package / hotplug2 / Makefile
index 6c2a0a10517936d91ce4ab59ff573351b64d3c05..6b69bac73349a28b237949eed497ada697dc0da1 100644 (file)
@@ -21,7 +21,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/hotplug2
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6 +udevtrigger
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
@@ -32,6 +31,9 @@ in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
 
 define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
+       $(INSTALL_DATA) ./files/hotplug2-init.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef