get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/staging/florian.git] / package / linux-atm / Makefile
index 000ea5c7008873688efb10f9e4fc15dad566668f..330f56bb54a4571bfd829aa1f16311d41b1cb165 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -41,6 +40,11 @@ define Package/atm-tools/description
   This package contains the Linux ATM tools.
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(INSTALL_BIN) $(SCRIPT_DIR)/config.sub $(SCRIPT_DIR)/config.guess $(PKG_BUILD_DIR)/
+endef
+
 define Build/Configure
        $(call Build/Configure/Default)
        # prevent autoheader invocation
@@ -62,11 +66,6 @@ ifneq ($(CONFIG_PACKAGE_linux-atm),)
        $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libatm.{a,so*} \
                $(1)/usr/lib/
   endef
-
-  define Build/UninstallDev
-       rm -rf  $(1)/usr/include/atm{,d,sap}.h \
-               $(1)/usr/lib/libatm.{a,so*}
-  endef
 endif
 
 define Package/linux-atm/install
@@ -76,7 +75,7 @@ endef
 
 define Package/atm-tools/install
        $(INSTALL_DIR) $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/atmarp{,d} $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/ipoa.sh $(1)/lib/network/
 endef