madwifi: clean up handling of various timings such as slot time, ack timeout, eifs...
[openwrt/staging/florian.git] / package / madwifi / Makefile
index 433cb61e15bbbfb6eb89a16a64a399bf8158cee6..8db820e5aa5f9a086fd62357182ab34062795e60 100644 (file)
@@ -38,10 +38,22 @@ else
   PATCH_DIR=./patches
 endif
 
+HAL_VERSION:=20090508
+HAL_FILE:=ath_hal-$(HAL_VERSION).tgz
+HAL_MD5SUM:=4ab7ae8bdb96c0be388c98bf8f92d5ca
+
 PKG_BUILD_DEPENDS:=wprobe
 
 include $(INCLUDE_DIR)/package.mk
 
+define Download/hal
+  FILE:=$(HAL_FILE)
+  URL:=http://mirror2.openwrt.org/sources
+  MD5SUM:=$(HAL_MD5SUM)
+endef
+$(eval $(call Download,hal))
+
+
 ifneq ($(CONFIG_TARGET_atheros),)
   BUS:=AHB
 else
@@ -50,11 +62,6 @@ else
   endif
 endif
 
-# XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
-  BUS:=
-endif
-
 ifneq ($(CONFIG_CPU_MIPS32_R2),)
   ifeq ($(ARCH),mips)
     HAL_TARGET:=mips32r2-be-elf
@@ -144,7 +151,7 @@ ifeq ($(findstring PCI,$(BUS)),PCI)
   MADWIFI_AUTOLOAD+= ath_pci
 endif
 
-MADWIFI_APPLETS:=80211stats athchans athctrl athkey athstats wlanconfig ath_info
+MADWIFI_APPLETS:=80211stats athchans athkey athstats wlanconfig ath_info
 ifdef CONFIG_MADWIFI_DEBUG
   MADWIFI_APPLETS += athdebug 80211debug
 endif
@@ -156,7 +163,7 @@ define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
   URL:=http://madwifi.org/
-  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml @LINUX_2_6
+  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @LINUX_2_6
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
 endef
@@ -176,7 +183,7 @@ MADWIFI_INC = \
        -I$(PKG_BUILD_DIR)/ath \
        -I$(PKG_BUILD_DIR)/ath_hal \
        -I$(PKG_BUILD_DIR)/net80211 \
-       -I$(STAGING_DIR)/usr/include \
+       -I$(STAGING_DIR)/usr/include/wprobe \
        -include $(PKG_BUILD_DIR)/include/compat.h
 
 MAKE_ARGS:= \
@@ -197,14 +204,10 @@ MAKE_VARS:= \
        COPTS="-DCONFIG_ATHEROS_RATE_DEFAULT='\"$(RATE_CONTROL)\"' -DATH_REVERSE_ENGINEERING=1" \
 
 ifeq ($(CONFIG_MADWIFI_UPSTREAM),)
-  HALFILE:=$(lastword $(sort $(wildcard ./ath_hal-*.tgz)))
-endif
-
-ifneq ($(HALFILE),)
   define Build/Prepare/HAL
        rm -rf $(PKG_BUILD_DIR)/tmp
        mkdir -p $(PKG_BUILD_DIR)/tmp
-       tar xvzf $(HALFILE) -C $(PKG_BUILD_DIR)/tmp
+       tar xvzf $(DL_DIR)/$(HAL_FILE) -C $(PKG_BUILD_DIR)/tmp
        $(CP) $(PKG_BUILD_DIR)/tmp/ath_hal*/* $(PKG_BUILD_DIR)/hal/
        rm -rf $(PKG_BUILD_DIR)/tmp
   endef