replace lots of manual install commands with INSTALL_* variables
[openwrt/staging/florian.git] / package / pptp / Makefile
index bb0710419bf92c49b482b32a773c753f0bae47c0..081ff4e52adeb64f0f3f87a18fd067d09717f07a 100644 (file)
@@ -31,12 +31,12 @@ define Package/pptp
 endef
 
 define Package/pptp/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/ppp
-       install -m0644 ./files/options.pptp $(1)/etc/ppp/
-       install -d -m0755 $(1)/lib/network
-       install -m0755 ./files/pptp.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
 endef
 
 $(eval $(call BuildPackage,pptp))