replace lots of manual install commands with INSTALL_* variables
[openwrt/staging/florian.git] / package / shfs / Makefile
index f4383a3f966ec6ebd13917d8e5a27e76e179f4af..2562001b7951377ace5c0246a8f0575909d2a00b 100644 (file)
@@ -77,15 +77,15 @@ define Build/Compile
 endef
 
 define Package/kmod-shfs/install
-       install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+       $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
                $(1)/lib/modules/$(LINUX_VERSION)/
 endef
 
 define Package/shfs-utils/install
-       install -m0755 -d $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/shfs{,u}mount $(1)/usr/bin/
-       install -m0755 -d $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/sbin/mount.shfs $(1)/sbin/
 endef