scripts/feeds update:
[openwrt/staging/florian.git] / scripts / feeds
index 9ab0d7e6df8a9a00ab3041449cbd27d30e72591f..dd0a6c2fcd04f70731d5a4e9f2ba3f41e1c354be 100755 (executable)
@@ -11,6 +11,10 @@ use Cwd 'abs_path';
 chdir "$FindBin::Bin/..";
 $ENV{TOPDIR}=getcwd();
 
+my $mk=`which gmake`;  # select the right 'make' program
+chomp($mk);            # trim trailing newline
+$mk or $mk = "make";   # default to 'make'
+
 my @feeds;
 my %build_packages;
 my %installed;
@@ -19,94 +23,137 @@ sub parse_config() {
        my $line = 0;
        my %name;
 
-       open FEEDS, "feeds.conf";
+       open FEEDS, "feeds.conf" or
+               open FEEDS, "feeds.conf.default" or
+               die "Unable to open feeds configuration";
        while (<FEEDS>) {
                chomp;
                s/#.+$//;
                next unless /\S/;
                my @line = split /\s+/, $_, 3;
+               my @src;
                $line++;
 
                my $valid = 1;
                $line[0] =~ /^src-\w+$/ or $valid = 0;
                $line[1] =~ /^\w+$/ or $valid = 0;
-               $line[2] =~ /\s/ and $valid = 0;
+               @src = split /\s+/, $line[2];
                $valid or die "Syntax error in feeds.list, line: $line\n";
 
                $name{$line[1]} and die "Duplicate feed name '$line[1]', line: $line\n";
                $name{$line[1]} = 1;
 
-               push @feeds, [@line];
+               push @feeds, [$line[0], $line[1], \@src];
        }
        close FEEDS;
 }
 
-sub update_index($$)
+sub update_location($$)
 {
        my $name = shift;
-       my $src = shift;
+       my $url  = shift;
+       my $old_url;
+
        -d "./feeds/$name.tmp" or mkdir "./feeds/$name.tmp" or return 1;
-       -d "./feeds/$name.tmp/info" or mkdir "./feeds/$name.tmp/info" or return 1;
 
-       system("make -s prepare-mk TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
-       system("make -s -f include/scan.mk IS_TTY=1 SCAN_TARGET=\"packageinfo\" SCAN_DIR=\"feeds/$name\" SCAN_NAME=\"package\" SCAN_DEPS=\"$ENV{TOPDIR}/include/package*.mk\" SCAN_DEPTH=4 SCAN_EXTRA=\"\" TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
-       system("ln -sf $name.tmp/.packageinfo ./feeds/$name.index");
+       if( open LOC, "< ./feeds/$name.tmp/location" )
+       {
+               chomp($old_url = readline LOC);
+               close LOC;
+       }
 
-       return 0;
+       if( !$old_url || $old_url ne $url )
+       {
+               if( open LOC, "> ./feeds/$name.tmp/location" )
+               {
+                       print LOC $url, "\n";
+                       close LOC;
+               }
+               return $old_url ? 1 : 0;
+       }
+
+       return 0;       
 }
 
-sub update_svn($$) {
+sub update_index($)
+{
        my $name = shift;
-       my $src = shift;
 
-       if (-d "./feeds/$name/.svn" ) {
-               system("(cd \"./feeds/$name\"; svn up)") == 0 or return 1;
-       } else {
-               system("rm -rf \"./feeds/$name\"");
-               system("svn co $src \"./feeds/$name\"") == 0 or return 1;
-       }
-       return update_index($name, $src);
-}
+       -d "./feeds/$name.tmp" or mkdir "./feeds/$name.tmp" or return 1;
+       -d "./feeds/$name.tmp/info" or mkdir "./feeds/$name.tmp/info" or return 1;
 
-sub update_cpy($$) {
-       my $name = shift;
-       my $src = shift;
+       system("$mk -s prepare-mk TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("$mk -s -f include/scan.mk IS_TTY=1 SCAN_TARGET=\"packageinfo\" SCAN_DIR=\"feeds/$name\" SCAN_NAME=\"package\" SCAN_DEPS=\"$ENV{TOPDIR}/include/package*.mk\" SCAN_DEPTH=5 SCAN_EXTRA=\"\" TMP_DIR=\"$ENV{TOPDIR}/feeds/$name.tmp\"");
+       system("ln -sf $name.tmp/.packageinfo ./feeds/$name.index");
 
-       system("cp -Rf $src ./feeds/$name");
-       return update_index($name, $src);
+       return 0;
 }
 
-sub update_link($$) {
-       my $name = shift;
-       my $src = abs_path(shift);
+my %update_method = (
+       'src-svn' => {
+               'init'          => "svn checkout '%s' '%s'",
+               'update'        => "svn update",
+               'controldir'    => ".svn"},
+       'src-cpy' => {
+               'init'          => "cp -Rf '%s' '%s'",
+               'update'        => ""},
+       'src-link' => {
+               'init'          => "ln -s '%s' '%s'",
+               'update'        => ""},
+       'src-git' => {
+               'init'          => "git clone --depth 1 '%s' '%s'",
+               'update'        => "git pull",
+               'controldir'    => ".git"},
+       'src-bzr' => {
+               'init'          => "bzr checkout --lightweight '%s' '%s'",
+               'update'        => "bzr update",
+               'controldir'    => ".bzr"},
+       'src-hg' => {
+               'init'          => "hg clone '%s' '%s'",
+               'update'        => "hg pull --update",
+               'controldir'    => ".hg"}
+);
 
-       system("ln -sf $src ./feeds/$name");
-       return update_index($name, $src);
-}
+# src-git: pull broken
+# src-cpy: broken if `basename $src` != $name
 
-sub update_git($$) {
+sub update_feed_via($$$$) {
+       my $type = shift;
        my $name = shift;
        my $src = shift;
-
-       if (-d "./feeds/$name/.git" ) {
-               system("GIT_DIR=./feeds/$name/.git git pull") == 0 or return 1;
+       my $relocate = shift;
+       
+       my $m = $update_method{$type};
+       my $localpath = "./feeds/$name";
+       my $safepath = $localpath;
+       $safepath =~ s/'/'\\''/;
+
+       if( $relocate || !$m->{'update'} || !-d "$localpath/$m->{'controldir'}" ) {
+               system("rm -rf '$safepath'");
+               system(sprintf($m->{'init'}, $src, $safepath)) == 0 or return 1;
        } else {
-               system("rm -rf \"./feeds/$name\"");
-               system("git-clone --depth 1 $src ./feeds/$name") == 0 or return 1;
+               system("cd '$safepath'; $m->{'update'}") == 0 or return 1;
        }
-       return update_index($name, $src);
+       
+       return 0;
 }
 
 sub get_feed($) {
        my $feed = shift;
+       my $file = "./feeds/$feed.index";
 
        clear_packages();
-       parse_package_metadata("./feeds/$feed.index") or return;
+
+       -f $file or do {
+               print "Ignoring feed '$feed' - index missing\n";
+               return;
+       };
+       parse_package_metadata($file) or return;
        return { %package };
 }
 
 sub get_installed() {
-       system("make -s prepare-tmpinfo");
+       system("$mk -s prepare-tmpinfo");
        clear_packages();
        parse_package_metadata("./tmp/.packageinfo");
        %installed = %package;
@@ -175,7 +222,7 @@ sub list {
        }
        if ($opts{s}) {
                foreach my $feed (@feeds) {
-                       printf "\%-32s\tURL: %s\n", $feed->[1], $feed->[2];
+                       printf "\%-32s\tURL: %s\n", $feed->[1], join(", ", @{$feed->[2]});
                }
                return 0;
        }
@@ -209,6 +256,8 @@ my %install_method = (
        'src-cpy' => \&install_generic,
        'src-link' => \&install_generic,
        'src-git' => \&install_generic,
+       'src-bzr' => \&install_generic,
+       'src-hg' => \&install_generic,
 );
 
 my %feed;
@@ -233,15 +282,17 @@ sub install_package {
        $feed = lookup_package($feed, $name);
        $feed or do {
                $installed{$name} and return 0;
-               warn "WARNING: No feed for package '$name' found.\n";
-               return 1;
+               # TODO: check if it's already installed within ./package directory
+               $srcpackage{$name} or -d "./package/$name" or warn "WARNING: No feed for package '$name' found, maybe it's already part of the standard packages?\n";
+               return 0;
        };
 
        my $pkg = $feed{$feed->[1]}->{$name} or return 1;
        $pkg->{name} or do {
                $installed{$name} and return 0;
+               # TODO: check if this is an alias package, maybe it's known by another name
                warn "WARNING: Package '$name' is not available in feed $feed->[1].\n";
-               return 1;
+               return 0;
        };
        my $src = $pkg->{src};
        my $type = $feed->[0];
@@ -251,13 +302,6 @@ sub install_package {
        # newly installed packages set the source package
        $installed{$src} and return 0;
 
-       # install all dependencies
-       foreach my $dep (@{$pkg->{depends}}) {
-               next if $dep =~ /@/;
-               $dep =~ s/^\+//;
-               install_package($feed, $dep) == 0 or $ret = 1;
-       }
-
        # check previously installed packages
        $installed{$name} and return 0;
        $installed{$src} = 1;
@@ -273,18 +317,32 @@ sub install_package {
                return 1;
        };
 
+       # install all dependencies
+       foreach my $vpkg (@{$srcpackage{$src}}, $pkg) {
+               foreach my $dep (@{$vpkg->{depends}}, @{$vpkg->{builddepends}}) {
+                       next if $dep =~ /@/;
+                       $dep =~ s/^\+//;
+                       $dep =~ s/^.+://;
+                       next unless $dep;
+                       install_package($feed, $dep) == 0 or $ret = 1;
+               }
+       }
+
        return $ret;
 }
 
 sub refresh_config {
        my $default = shift;
-       $default or $default = "o";
 
        # workaround for timestamp check
        system("rm -f tmp/.packageinfo");
 
        # refresh the config
-       system("make oldconfig CONFDEFAULT=\"$default\" Config.in >/dev/null 2>/dev/null");
+       if ($default) { 
+               system("$mk oldconfig CONFDEFAULT=\"$default\" Config.in >/dev/null 2>/dev/null");
+       } else {
+               system("$mk defconfig Config.in >/dev/null 2>/dev/null");
+       }
 }
 
 sub install {
@@ -293,7 +351,13 @@ sub install {
        my $feed;
        my $ret = 0;
 
-       getopts('ap:d:', \%opts);
+       getopts('ap:d:h', \%opts);
+
+       if ($opts{h}) {
+               usage();
+               return 0;
+       }
+
        get_installed();
 
        foreach my $f (@feeds) {
@@ -313,8 +377,6 @@ sub install {
                                        my $p = $package{$name};
                                        if( $p->{name} ) {
                                                install_package($feed, $p->{name}) == 0 or $ret = 1;
-                                       } else {
-                                               warn "WARNING: Package '$name' is not available\n";
                                        }
                                }
                        }
@@ -336,13 +398,25 @@ sub install {
 }
 
 sub uninstall {
+       my %opts;
        my $name;
        my $uninstall;
 
-       if ($ARGV[0] eq '-a') {
-               system("rm -rf ./package/feeds");
+       getopts('ah', \%opts);
+
+       if ($opts{h}) {
+               usage();
+               return 0;
+       }
+
+       if ($opts{a}) {
+               system("rm -rvf ./package/feeds");
                $uninstall = 1;
        } else {
+               if($#ARGV == -1) {
+                       warn "WARNING: no package to uninstall\n";
+                       return 0;
+               }
                get_installed();
                while ($name = shift @ARGV) {
                        my $pkg = $installed{$name};
@@ -360,6 +434,89 @@ sub uninstall {
        return 0;
 }
 
+sub update_feed($$$$)
+{
+       my $type=shift;
+       my $name=shift;
+       my $src=shift;
+       my $perform_update=shift;
+       my $force_relocate=update_location( $name, "@$src" );
+
+       if( $force_relocate ) {
+               warn "Source of feed $name has changed, replacing copy\n";
+       }
+       $update_method{$type} or do {
+               warn "Unknown type '$type' in feed $name\n";
+               return 1;
+       };
+       $perform_update and do {
+               my $failed = 1;
+               foreach my $feedsrc (@$src) {
+                       warn "Updating feed '$name' from '$feedsrc' ...\n";
+                       next unless update_feed_via($type, $name, $feedsrc, $force_relocate) == 0;
+                       $failed = 0;
+                       last;
+               }
+               $failed and do {
+                       warn "failed.\n";
+                       return 1;
+               };
+       };
+       warn "Create index file './feeds/$name.index' \n";
+       update_index($name) == 0 or do {
+               warn "failed.\n";
+               return 1;
+       };
+       return 0;
+}
+
+sub update {
+       my %opts;
+       my $feed_name;
+       my $perform_update=1;
+
+       $ENV{SCAN_COOKIE} = $$;
+       $ENV{KBUILD_VERBOSE} = 99;
+
+       getopts('ahi', \%opts);
+
+       if ($opts{h}) {
+               usage();
+               return 0;
+       }
+
+       if ($opts{i}) {
+               # don't update from (remote) repository
+               # only re-create index information
+               $perform_update=0;
+       }
+
+       -d "feeds" or do {
+                       mkdir "feeds" or die "Unable to create the feeds directory";
+               };
+
+       if ( ($#ARGV == -1) or $opts{a}) {
+               foreach my $feed (@feeds) {
+                       my ($type, $name, $src) = @$feed;
+                       update_feed($type, $name, $src, $perform_update);
+               }
+       } else {
+               while ($feed_name = shift @ARGV) {
+                       foreach my $feed (@feeds) {
+                               my ($type, $name, $src) = @$feed;
+                               if($feed_name ne $name) {
+                                       next;
+                               }
+                               update_feed($type, $name, $src, $perform_update);
+                       }
+               }
+       }
+
+       refresh_config();
+
+       return 0;
+}
+
 sub usage() {
        print <<EOF;
 Usage: $0 <command> [options]
@@ -381,9 +538,13 @@ Commands:
            -r <feedname>: Only search in this feed
 
        uninstall -a|<package>: Uninstall a package
+       Options:
            -a :           Uninstalls all packages.
 
-       update:            Update packages and lists of feeds in feeds.conf .
+       update -a|<feedname(s)>: Update packages and lists of feeds in feeds.conf .
+       Options:
+           -a :           Update all feeds listed within feeds.conf. Otherwise the spezified feeds will be updated.
+           -i :           Recreate the index only. No feed update from repository is performed.
 
        clean:             Remove downloaded/generated files.
 
@@ -391,35 +552,9 @@ EOF
        exit(1);
 }
 
-my %update_method = (
-       'src-svn' => \&update_svn,
-       'src-cpy' => \&update_cpy,
-       'src-link' => \&update_link,
-       'src-git' => \&update_git
-);
-
 my %commands = (
        'list' => \&list,
-       'update' => sub {
-               -d "feeds" or do {
-                       mkdir "feeds" or die "Unable to create the feeds directory";
-               };
-               $ENV{SCAN_COOKIE} = $$;
-               $ENV{KBUILD_VERBOSE} = 99;
-               foreach my $feed (@feeds) {
-                       my ($type, $name, $src) = @$feed;
-                       $update_method{$type} or do {
-                               warn "Unknown type '$type' in feed $name\n";
-                               next;
-                       };
-                       warn "Updating feed '$name'...\n";
-                       &{$update_method{$type}}($name, $src) == 0 or do {
-                               warn "failed.\n";
-                               return 1;
-                       };
-               }
-               return 0;
-       },
+       'update' => \&update,
        'install' => \&install,
        'search' => \&search,
        'uninstall' => \&uninstall,