major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/florian.git] / target / linux / atheros / Makefile
index 611345f4bbf5f25e7debcbf886ec59032288f616..fc48efd5ded8b297f2cfa502209c3a3fce850b9d 100644 (file)
@@ -13,14 +13,15 @@ FEATURES:=squashfs jffs2
 
 LINUX_VERSION:=2.6.22.4
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-madwifi
+
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-madwifi
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))